Results 1 to 6 of 6

Thread: root initial password for mysql?

Hybrid View

  1. #1
    Join Date
    May 2006
    Posts
    29
    Rep Power
    9

    Default root initial password for mysql?

    Hello Sirs,
    I would like to know what root initial password is attributed to the mysql database, thanks in advanced for your help.

    Fabio

  2. #2
    Join Date
    Aug 2006
    Location
    Somerset, UK
    Posts
    22
    Rep Power
    9

    Default

    If you are logged in as zimbra then there is no password,

    so, log in as root and type:

    % su - zimbra
    % mysql
    % show databases ;
    ...

    Does that help?

    David

  3. #3
    Join Date
    May 2006
    Posts
    29
    Rep Power
    9

    Thumbs up Ok

    Hello David,
    it's true, thanks for your answer.

    Fabio

  4. #4
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    although the zimbra user is setup to run the cli client without a password, mysql does have a root password that you need to use for anything else, e.g. phpmyadmin. look in /opt/zimbra/conf/localconfig.xml and look for mysql_root_password.

  5. #5
    Join Date
    Aug 2006
    Location
    Somerset, UK
    Posts
    22
    Rep Power
    9

    Default

    Thanks for clarifying that. If Fabio had changed the password it would have broken other access routes using this config. Phew...

    D.

  6. #6
    Join Date
    May 2006
    Posts
    29
    Rep Power
    9

    Thumbs up Resolved problem

    Hello Sirs,
    thanks for your help, I had already resolved my problem for the change of password using the script zmmypasswd, that uses standard commands mysql and the command zmlocalconfig to modify the inside variable of Zimbra (tomcat) as for the note mysql_root_password.
    Now I can use PhpMyAdmin to operate more easily on the database mysql.
    However thanks to your help I have finally discovered whether to find the values of these variable (/ opt/zimbra/conf/localconfig.xml).

    Fabio
    Last edited by Fabio; 08-25-2006 at 01:51 AM.

Similar Threads

  1. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 06:47 AM
  2. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  3. Login does not appear
    By alexz in forum Administrators
    Replies: 10
    Last Post: 04-18-2006, 06:46 AM
  4. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •