Results 1 to 3 of 3

Thread: zimbra-cisco 7940 ldap integration

  1. #1
    Join Date
    Feb 2006
    Posts
    8
    Rep Power
    9

    Default zimbra-cisco 7940 ldap integration

    I'm setting up a new office phone system, using a version of Asterisk and Cisco 7940 phones. The Cisco phones can display a company phone directory. The directory is itself is an XML file on a central web server. I'm wondering if anyone has a script that can parse Zimbra's LDAP directory and output an XML file in the proper format, so that the staff directory on the phones would be the staff directory in Zimbra.

    Because the phones read the XML file each time a user presses the directory button, the directory on a phone would update live against the directory on Zimbra. The only needed fields would be those for name and phone number. Ideally, any record without a phone number would be omitted from the XML directory, as to keep service accounts from displaying on the phones.

    Details on the format of directory.xml are here:
    http://www.voip-info.org/wiki-Asterisk+phone+cisco+79xx
    (scroll down to Company Telephone Directory)

    If no one has a solution already, I'll post back when I find one. If you're already into Zimbra and VOIP, and would like to bid on the project, please let me know that, too.

    Thanks,
    Adam

  2. #2
    Join Date
    Mar 2010
    Posts
    8
    Rep Power
    5

    Default Too late but...

    I have just write a features for CiscoXMLServices that do it through json request. You can use it or ask me for the php code.

    Enrico Pasqualotto.

  3. #3
    Join Date
    Oct 2010
    Posts
    1
    Rep Power
    5

    Default

    Hi, i'd be interrested in that script please!

    I too have just installed myself an asterisk server and have a Zimbra server i'd like to interface in the company phone directory.

    Cheers

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 12:17 PM
  2. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  3. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-03-2006, 11:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •