Hi all,

I will start with a brief synopsis of my setup:

1. I use zimbra 5.0.12 (ubuntu 32bit) as our main mail server
2. We are looking at going 64bit and faster procs and zimbra 6
3. So I started out by creating a mail server called with hostname as "mail2.*".
4. Then I created all accounts using a script and zmprov.
5. Then copied "all" mail over using imapsync

Now that I have a current snapshot of mail I want to use zmsetservername to change the servername from "mail" to "mail2" I turn off(power down) mail and then I run the command 'zmsetservername -n mail.chinooksd.ca' and wait.

The errors I get complain about

"Unable to determine enabled services from ldap.
Unable to determine enabled services. Cache is out of date or doesn’t exist."

I then set my hosts file to:
rcaudill@mail2:~$ cat /etc/hosts
127.0.0.1 localhost.localdomain localhost
*.*.*.* mail2.chinooksd.ca mail2

I also change "/etc/hostname" to mail.chinooksd.ca and then I update my networking to reflect the new ip.

Dig shows:

; <<>> DiG 9.7.0-P1 <<>> chinooksd.ca mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57892
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 4

;; QUESTION SECTION:
;chinooksd.ca. IN MX

;; ANSWER SECTION:
chinooksd.ca. 600 IN MX 10 mail2.chinooksd.ca.
chinooksd.ca. 600 IN MX 5 mail.chinooksd.ca.

;; AUTHORITY SECTION:
chinooksd.ca. 600 IN NS fulcrum.sasknet.sk.ca.
chinooksd.ca. 600 IN NS stuka.sasknet.sk.ca.

;; ADDITIONAL SECTION:
mail.chinooksd.ca. 600 IN A 207.195.80.254
mail2.chinooksd.ca. 600 IN A 207.195.80.209
stuka.sasknet.sk.ca. 2762 IN A 142.165.200.10
fulcrum.sasknet.sk.ca. 3061 IN A 142.165.21.10

;; Query time: 137 msec
;; SERVER: 172.16.1.254#53(172.16.1.254)
;; WHEN: Wed Jul 14 07:00:50 2010
;; MSG SIZE rcvd: 190


When I reboot the server I still get the previous messages above. I then read various docs and think it could be the certs.
So then I run:

"zmcertmgr createca -new"
"zmcertmgr createcrt self -new"
"zmcertmgr deploycrt self"


And yet I still get the same problems. I then run "zmsetservername -n mail2.chinooksd.ca" and update hosts,hostname, and networking and restart and mail2 works again. Does anyone have any ideas what could be the problem?

Thanks,
Rick Caudill