Results 1 to 4 of 4

Thread: Zimbra authentication error

  1. #1
    Join Date
    Jun 2006
    Rep Power

    Default Zimbra authentication error


    I have setup zimbra on an internal server, and it is workiing fine. It uses our local ldap server to authenticate the users. However, I want to be able to access the server from the external world. I have a firewall protecting the network.

    Zimbra is running on fc4.

    I have a server running apache in the dmz that forwards the webmail requests through the fw via port 18880. When I am outside my network and go to http://webmail... The zimbra login page comes up. However, when I go to login, I get an error message:
    An unknown application error has occurred. Please correct any errors and retry.

    I can see the traffic using tcpdump on the zimbra server, and it appears to be fine. I cannot find any error messages in the log files as to why the authentication might be failing.

    My external apache configuration is:
    <VirtualHost x.x.x.x:80>
    RedirectPermanent /
    ProxyPass / http://x.x.x.x:18880/
    ProxyPassReverse / http://x.x.x.x:18880/
    ProxyVia Off

    Is there perhaps a proxy config problem perhaps?

    I have tried a number of different apache configs, but I see to get the same result each time.

    Any help would be appreciated, and any additional information I can provide.


  2. #2
    Join Date
    Jun 2006
    Rep Power

    Default Update

    I am still looking at this issue, but after some research and some help from paros, it looks like I have narrowed down where the issue is.

    Here is the request made by my external browser:
    <soap:Envelope xmlns:soap=""><soap:Header><context xmlns="urn:zimbra"><nosession/><format type="js"/></context></soap:Header><soap:Body><AuthRequest xmlns="urn:zimbraAccount"><account by="name"></account><password>xxxxx</password></AuthRequest></soap:Body></soap:Envelope>

    This is the response:
    <soap:Envelope xmlns:soap=""><soap:Body><soap:Fault><soap:Code><soap: Value>soap:Receiver</soap:Value></soap:Code><soap:Reason><soap:Text>system failure: Request not allowed on port 18880</soap:Text></soap:Reason><soapetail><Error xmlns="urn:zimbra"><Code>service.FAILURE</Code><Trace>com.zimbra.cs.service.ServiceException : system failure: Request not allowed on port 18880
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at ternalDoFilter(
    at Filter(
    at org.apache.catalina.core.StandardWrapperValve.invo ke(
    at org.apache.catalina.core.StandardContextValve.invo ke(
    at org.apache.catalina.core.StandardHostValve.invoke(
    at org.apache.catalina.valves.ErrorReportValve.invoke (
    at org.apache.catalina.core.StandardEngineValve.invok e(
    at org.apache.catalina.valves.AccessLogValve.invoke(A
    at org.apache.catalina.connector.CoyoteAdapter.servic e(
    at org.apache.coyote.http11.Http11Processor.process(H
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt
    at Socket(
    at ead.runIt(
    at org.apache.tomcat.util.threads.ThreadPool$ControlR

    Hopefully this provides more insight into my problem. I am not very familiar with SOAP.

    Here is a quick rundown on what happens from a network standpoint:

    Request --->
    External server receives request, apache uses virtual host and forwards to port 18880 -->
    fw takes request on port 18880 and forwards to internal zimbra on port 80 -->
    internal zimbra receives request on port 80.

    Thanks again,

  3. #3
    Join Date
    Aug 2005
    Rep Power

    Default Fixed in 4.0

    This was fixed in 4.0. We were using the port the client was connecting to rather than the port the server was fielding the request on in a few places in the code.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    Join Date
    Jun 2006
    Rep Power


    Thank you. The upgrade to 4 did it.


Similar Threads

  1. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  2. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  3. Replies: 7
    Last Post: 01-24-2007, 10:03 PM
  4. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 11:59 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts