Results 1 to 4 of 4

Thread: Move/copy shared Subfolder

  1. #1
    Join Date
    May 2010
    Rep Power

    Default Move/copy shared Subfolder


    Interresting Problem.

    I Tried teh following:
    Account A get the share from Account B.
    Its a Mail folder.
    I can read and write mail there (so from a i can also drop a collection mails and so on)
    i also cann create a subfolder.

    But i cannot move a hole Folder from or to the share.

    Means if i try to move a subfolder from the share i get the Message i cannot move that folder to that Destination.
    When i try move or copy a folder to the share i get an unknown error

    method:    FolderActionRequest
    msg:    cannot copy object: 36889
    code:    mail.CANNOT_COPY
    detail:    soap:Sender
    trace:    com.zimbra.cs.mailbox.MailServiceException: cannot copy object: 36889 ExceptionId:btpool0-86:// Code:mail.CANNOT_COPY Arg:(itemId, IID, "36889") at com.zimbra.cs.mailbox.MailServiceException.CANNOT_COPY( at com.zimbra.cs.service.mail.ItemActionHelper.executeRemote( at com.zimbra.cs.service.mail.ItemActionHelper.schedule( at com.zimbra.cs.service.mail.ItemActionHelper.MOVE( at com.zimbra.cs.service.mail.ItemAction.handleCommon( at com.zimbra.cs.service.mail.FolderAction.handle( at com.zimbra.soap.SoapEngine.dispatchRequest( at com.zimbra.soap.DocumentHandler.proxyRequest( at com.zimbra.soap.DocumentHandler.proxyRequest( at com.zimbra.cs.service.mail.ItemAction.proxyRemoteItems( at com.zimbra.cs.service.mail.ItemAction.handleCommon( at com.zimbra.cs.service.mail.FolderAction.handle( at com.zimbra.soap.SoapEngine.dispatchRequest( at com.zimbra.soap.SoapEngine.dispatch( at com.zimbra.soap.SoapEngine.dispatch( at com.zimbra.soap.SoapServlet.doWork( at com.zimbra.soap.SoapServlet.doPost( at javax.servlet.http.HttpServlet.service( at com.zimbra.cs.servlet.ZimbraServlet.service( at javax.servlet.http.HttpServlet.service( at org.mortbay.jetty.servlet.ServletHolder.handle( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at com.zimbra.cs.servlet.SetHeaderFilter.doFilter( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at org.mortbay.servlet.UserAgentFilter.doFilter( at org.mortbay.servlet.GzipFilter.doFilter( at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter( at org.mortbay.jetty.servlet.ServletHandler.handle( at at org.mortbay.jetty.servlet.SessionHandler.handle( at org.mortbay.jetty.handler.ContextHandler.handle( at org.mortbay.jetty.webapp.WebAppContext.handle( at org.mortbay.jetty.handler.ContextHandlerCollection.handle( at org.mortbay.jetty.handler.HandlerCollection.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.handler.rewrite.RewriteHandler.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.handler.DebugHandler.handle( at org.mortbay.jetty.handler.HandlerWrapper.handle( at org.mortbay.jetty.Server.handle( at org.mortbay.jetty.HttpConnection.handleRequest( at org.mortbay.jetty.HttpConnection$RequestHandler.content( at org.mortbay.jetty.HttpParser.parseNext( at org.mortbay.jetty.HttpParser.parseAvailable( at org.mortbay.jetty.HttpConnection.handle( at at org.mortbay.thread.BoundedThreadPool$
    but i can create new folder and delete (old and new folder) without an issue.

    The share has admin permissions.
    I Tried it with the webinterface (netwokr edition)
    Zimbra desktop 2.0 beta
    Outlook with connector

    No luck in any direction - moving subfolders

    so the only workaround i see at the moment is export the hole structure to a tar.gz and reimport in the target account.

    any better ideas ? its really bad if i have to make a new Folder move mails and then delete the original subfolder. that cant be the way in zimbra i means this is a very basic

  2. #2
    Join Date
    Jul 2007
    Rep Power


    been like this since 5.x, but i can't seem to find a rfe for it. i can't believe one hasn't been filed, i'm just not good at searching bugzilla.

  3. #3
    Join Date
    May 2010
    Rep Power


    Damn,.. and i hoped so much i got a misconfig on my server - i prayed for a mistake by myself :-)

    ok i found it: Bug 43733 – Can't move subfolders in shared email folder

    just type subfolder in the searchbox got 2 similar bugs but this seems the relevant one


  4. #4
    Join Date
    May 2010
    Rep Power


    oh man are you kiddn

    it looks like its really just a rule which prevent from moving folder - to prevent such an expensive operation and killing the server.

    so far so bad.

    but the real fun is.
    you can import into an shared folder from outlook:

    ife moved the folder to an secondary pst file
    and used outlooks import direktly into the shared account
    (the zimbra import lost 200 of 600mb somehow)

    we will see if there are some issues with that but it looks good.

    this is really anoying, specially i dont know how i can explain this behaivior to an customer - really ife no idea.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. Replies: 3
    Last Post: 05-08-2008, 10:58 AM
  3. Replies: 1
    Last Post: 03-12-2008, 02:58 PM
  4. Replies: 2
    Last Post: 02-27-2008, 12:59 PM
  5. Problem with shared items in 5.0b2
    By p24t in forum Administrators
    Replies: 0
    Last Post: 08-20-2007, 12:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts