Results 1 to 4 of 4

Thread: [SOLVED] ldap startup failed with exit code 1

  1. #1
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default [SOLVED] ldap startup failed with exit code 1

    Hi,

    I have been following this site to migrate all data from old zimbra 5.0.7 installation to new zimbra 5.0.24.

    However, I always come up with this error:
    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.07292010-163450.log
    Starting ldap...done.
    Setting defaults...done.
    Upgrading from 5.0.7_GA_2444 to 5.0.24_GA_3356
    Stopping zimbra services
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql
    Starting logger mysql
    This appears to be 5.0.7_GA
    Redolog Version: 1.22 New Redolog Version: 1.24
    Thu Jul 29 16:35:59 2010: Verified redolog version 1.22.
    Thu Jul 29 16:35:59 2010: Updating Redolog schema version from 1.22 to 1.24.
    Schema upgrade required
    Running /opt/zimbra/libexec/scripts/migrate20080909-DataSourceItemTable.pl
    Thu Jul 29 16:36:01 2010: Verified schema version 52.
    Thu Jul 29 16:36:46 2010: Verified schema version 52.
    Thu Jul 29 16:36:46 2010: Updating DB schema version from 52 to 53.
    Stopping mysql
    An upgrade of the logger schema is necessary from version 5
    Running /opt/zimbra/libexec/scripts/migrateLogger6-qid.pl
    Thu Jul 29 16:37:02 2010: Verified schema version 5.
    Thu Jul 29 16:37:02 2010: Modifying postfix_qid size
    Thu Jul 29 16:37:56 2010: Verified schema version 5.
    Thu Jul 29 16:37:56 2010: Updating logger DB schema version from 5 to 6.
    Stopping logger mysql
    Checking ldap status
    Starting ldap
    ldap startup failed with exit code 1
    bdb_db_close: txn_checkpoint failed: Invalid argument (22)
    backend_startup_one: bi_db_open failed! (-30978)
    bdb_db_close: alock_close failed
    UPGRADE FAILED - exiting
    I have customized ldap schema on the old zimbra installation so I can use samba with it. This is my reference.

    Early part of the log, we can see that ldap started normally. Then it tried to startup again but failed. With this I cannot continue.

    Any help is greatly appreciated.

    Hex

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Last edited by phoenix; 07-29-2010 at 11:49 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    Thanks, I will try these solutions.

  4. #4
    Join Date
    Jun 2010
    Posts
    16
    Rep Power
    5

    Default

    ldap now started by using dbrecover on
    ldap database and
    admin ldap database (i missed this before)

    Thanks!

Similar Threads

  1. [SOLVED] ldap - cache is out of date or doesn't exist
    By aidanewen in forum Administrators
    Replies: 11
    Last Post: 08-31-2010, 12:10 AM
  2. Replies: 2
    Last Post: 05-13-2008, 06:35 PM
  3. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 11:12 AM
  4. LDAP Problem. Upgrading from 3.0 to 4.5 FAILED
    By dealt in forum Installation
    Replies: 16
    Last Post: 02-18-2007, 11:40 PM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •