Results 1 to 1 of 1

Thread: openssl problem

  1. #1
    Join Date
    Dec 2007
    Posts
    9
    Rep Power
    8

    Default openssl problem

    Hello

    today I had strange problem with ssl. I was trying to deploy commercial ssl certificate from thawte. System's openssl verify was succesfull but zimbra's openssl verify ended with error. See below.

    mail:~/w/a# openssl verify -CAfile ca-bundle.cert mail.crt
    mail.crt: OK
    mail:~/w/a# /opt/zimbra/openssl/bin/openssl verify -CAfile ca-bundle.cert mail.crt
    mail.crt: /C=US/O=thawte, Inc./OU=Certification Services Division/OU=(c) 2006 thawte, Inc. - For authorized use only/CN=thawte Primary Root CA
    error 2 at 2 depth lookup:unable to get issuer certificate

    I was not sure what is the problem with zimbra's openssl and needed to deploy certificate quickly so I workarounded it by:
    mv /opt/zimbra/openssl/bin/openssl /opt/zimbra/openssl/bin/openssl.zimbra
    ln -s /usr/bin/openssl /opt/zimbra/openssl/bin/openssl

    With this workaround I was able to verify and deploy certificate. Do you have idea what is wrong with zimbra's openssl?

    Thank you.
    Last edited by wooo; 08-04-2010 at 08:23 AM.

Similar Threads

  1. Problem after upgrade to 5.0
    By bmannella in forum Installation
    Replies: 6
    Last Post: 01-26-2008, 01:35 AM
  2. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 07:07 PM
  3. Backup problem
    By polaco999 in forum Installation
    Replies: 1
    Last Post: 11-26-2007, 12:13 PM
  4. [SOLVED] webmail relay problem
    By pst in forum Administrators
    Replies: 2
    Last Post: 10-29-2007, 02:24 AM
  5. [SOLVED] Small problem stopping zimbra
    By jml75 in forum Administrators
    Replies: 13
    Last Post: 07-13-2006, 09:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •