I've just installed Zimbra on a fresh install of Centos 4 and I can't receive email. A quick check of the /var/log/zimbra.log shows the following (after a restart of Zimbra):

Oct 16 12:58:48 mail zimbramon[12705]: 12705:info: Doing startup
Oct 16 12:58:48 mail postfix/smtpd[16815]: disconnect from localhost.localdomain[127.0.0.1]
Oct 16 12:58:49 mail zimbramon[16819]: 16819:info: Zimbra Monitor startup: 16819
Oct 16 12:58:49 mail zimbramon[16819]: 16819:info: Process 1402 not found - removing /opt/zimbra/zimbramon/FIFO/zm.pid
Oct 16 12:58:49 mail zimbramon[16850]: 16850:info: Status monitor startup
Oct 16 12:58:49 mail zimbramon[16851]: 16851:info: Creating soap server on port 7777
Oct 16 12:58:56 mail postfix/smtpd[16815]: connect from test.DNSstuff.com[66.36.241.109]
Oct 16 12:58:58 mail postfix/smtpd[16815]: NOQUEUE: reject: RCPT from test.DNSstuff.com[66.36.241.109]: 554 <mlind@mydomain.ca>: Relay access denied; from=<TestedFrom-24.71.34.95@DNSreport.com> to=<mlind@mydomain.ca> proto=SMTP helo=<test.DNSreport.com>
Oct 16 12:58:58 mail postfix/smtpd[16815]: lost connection after RCPT from test.DNSstuff.com[66.36.241.109]
Oct 16 12:58:58 mail postfix/smtpd[16815]: disconnect from test.DNSstuff.com[66.36.241.109]

Why is it denying relaying when the email is to the domain that is hosted on the server???
  • I've tweaked /opt/zimbra/postfix/main.cf to set myhostname to mail.mydomain.ca without any apparent effect.
  • mlind is a valid account in Zimbra and has as an alias a valid shell account name, though I don't expect the shell account to have any effect on this.
  • Turning off dns lookups on the MTA tab also has no effect.


Looking through the admin guide and nothing jumps out at me... What am I missing?

Martin.