Results 1 to 3 of 3

Thread: [SOLVED] Javascript errors in Admin Console after upgrade

  1. #1
    Join Date
    Jan 2008
    Posts
    30
    Rep Power
    7

    Default [SOLVED] Javascript errors in Admin Console after upgrade

    Running on Ubuntu 6.4 LTS 32bit

    We previously had the network edition and upgraded to v6.

    Thereafter we migrated successfully to the open source edition, 6.0.4

    Due to a missing preferences option in 6.0.4 we upgraded today to 6.0.6

    Thereafter I could no longer edit any user account as a result of a javascript error.

    I then upgraded to 6.0.7 GA and have the same problem.

    The error is:

    Code:
    JavaScript error encountered in method 
    ZaAccountViewController.prototype._setView message: this._view is 
    undefined fileName: https://zimbra.example.com:7071/zimbraAdmin
    /js/Admin_all.js.zgz?v=100611004005 lineNumber: 10771 stack: ([object 
    Object],true,(void 0))@https://zimbra.example.com:7071/zimbraAdmin
    /js/Admin_all.js.zgz?v=100611004005:10771 ([object Object],true,(void 
    0))@https://zimb...
    If I try and edit a COS I get this error:

    Code:
    JavaScript error encountered in method 
    ZaCosController.prototype._setView message: com_zimbra_delegatedadmin is 
    not defined fileName: https://zimbra.example.com:7071/service/zimlet
    /res/Zimlets-nodev_all.js.zgz.js?v=100611004005 lineNumber: 4826 stack: 
    ([object Object],[object Object])@https://zimbra.example.com:7071/service
    /zimlet/res/Zimlets-nodev_all.js.zgz.js?v=100611004005:48...
    Essentially I can no longer adminsiter the server from the Admin console.

    Any suggestions?

  2. #2
    Join Date
    Jan 2008
    Posts
    30
    Rep Power
    7

    Default

    Update

    This was solved with:

    /opt/zimbra/bin/zmzimletctl undeploy com_zimbra_delegatedadmin

    followed by a zimbra restart and cache clearing on the browser.

    Looks like there's an issue though, since we had been running a GA release without problem before. Hopefully this can be fixed so future GA releases don't bork for previous NE customers.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by albanach View Post
    Update

    This was solved with:

    /opt/zimbra/bin/zmzimletctl undeploy com_zimbra_delegatedadmin

    followed by a zimbra restart and cache clearing on the browser.

    Looks like there's an issue though, since we had been running a GA release without problem before. Hopefully this can be fixed so future GA releases don't bork for previous NE customers.
    You'll need to file a bug report for that please.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. View & Manage Mobile Devices in Admin Console (6.x)
    By bradb21 in forum Administrators
    Replies: 3
    Last Post: 09-06-2009, 11:35 PM
  2. "False" Logger Admin Email Alerts After 5.0.15 Upgrade?
    By LMStone in forum Administrators
    Replies: 1
    Last Post: 04-01-2009, 09:15 AM
  3. admin console problems on login after upgrade
    By dcorso in forum Installation
    Replies: 2
    Last Post: 02-01-2009, 01:38 PM
  4. [SOLVED] can't log into admin console
    By harvey186 in forum Installation
    Replies: 2
    Last Post: 01-02-2009, 08:14 AM
  5. My admin console is not loading
    By danny.sierra@omtech.net in forum Administrators
    Replies: 2
    Last Post: 12-11-2007, 05:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •