Results 1 to 2 of 2

Thread: [SOLVED] 6.05 -> 6.07 Upgrade Fails on LDAP Errors

Hybrid View

  1. #1
    Join Date
    Aug 2010
    Posts
    3
    Rep Power
    5

    Default [SOLVED] 6.05 -> 6.07 Upgrade Fails on LDAP Errors

    Attempting to upgrade a 6.05 server to a 6.07 server (OSR). Appears to fail and loop when it attempts to restart the LDAP server:

    Code:
    Stopping ldap...done.
    Upgrade complete.
    
    Running bdb db_recover...done.
    Running zmldapapplyldif...failed.
    Checking ldap status....not running.
    Starting ldap...failed with exit code: 256.
    hdb_db_open: database "": db_open(/opt/zimbra/data/ldap/hdb/db/id2entry.bdb) failed: Invalid argument (22).
    backend_startup_one (type=hdb, suffix=""): bi_db_open failed! (22)
    bdb_db_close: database "": alock_close failed
    [repeat from 'Running bdb db_recover...done.]
    This continues until I break out of the install. I am running Ubuntu 6.06 LTS 32bit.

    Some additional info:

    The server has a commercial Cert.
    The server started as a 5.x server.
    Their are no 3rd party extensions installed.

    Any ideas on what I should check, or what might be the problem? Everything appears fine under 6.05.

    Thanks in advance.

    Stuart Sheldon

  2. #2
    Join Date
    Aug 2010
    Posts
    3
    Rep Power
    5

    Default *** Update ***

    Turns out, it was a corrupted LDAP bdb database. a slapcat / slapadd fixed it.

    Stu

Similar Threads

  1. ldap sync broken in post-6.0.5 upgrade
    By gnyce in forum Administrators
    Replies: 1
    Last Post: 02-22-2010, 02:35 PM
  2. Replies: 2
    Last Post: 04-17-2008, 11:28 AM
  3. LDAP Replicas 4.5.x > 5.0.x
    By mmorse in forum Announcements
    Replies: 0
    Last Post: 01-28-2008, 04:05 PM
  4. Mac OSX install: Java errors & LDAP CA error
    By jefbear in forum Installation
    Replies: 9
    Last Post: 12-16-2006, 03:39 PM
  5. Force LDAP Upgrade?
    By jholder in forum Administrators
    Replies: 3
    Last Post: 09-07-2006, 09:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •