Results 1 to 2 of 2

Thread: CASifying Zimbra with Zimbra Proxy

Hybrid View

  1. #1
    Join Date
    Aug 2009
    Posts
    3
    Rep Power
    6

    Default CASifying Zimbra with Zimbra Proxy

    We are in the process of CASifying (SSO, CAS | Jasig Community) some of our services and ran into some issues with CASifying Zimbra. We currently have 2 mailbox servers hooked up to a Zimbra Proxy that redirects the user based on their mailbox to the correct mail server (IMAP/POP/HTTP). We have gone through the documents to CASify Zimbra v6, but our web developer hit a road block with ticket retrieval from Zimbra. Our preauth, along with the CAS client is hosted on both Zimbra mailbox servers (not the proxy, is this the problem?). Upon login, the user hits the proxy and is correctly redirected to CAS, logs in and is granted a ticket, but the proxy is unaware of the ticket, since the ticket is issued to the mailbox server, not the proxy. Does anyone have any solution for this or experience with CASifying Zimbra in a proxied Zimbra environment?

    Any help would be greatly appreciated. We are running CAS 3.3.5 and Zimbra 6.0.6.

    Thank you very much!

  2. #2
    Join Date
    Jul 2009
    Posts
    107
    Rep Power
    6

    Default

    We've been using CAS (the one bundled with SunGard Luminis) with the zimbra proxy without any issues for a while now. One thing I've notice is that the proxy is very sensitive to changes and will need stopping and starting if there has been a change to the mailbox server's zimbra.web.xml.in config file or the preauth.jsp page.

Similar Threads

  1. Migrate Zimbra Server to VMware
    By Oasy in forum Administrators
    Replies: 11
    Last Post: 07-14-2010, 08:13 AM
  2. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 05:42 PM
  3. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  4. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •