Results 1 to 4 of 4

Thread: [SOLVED] com_zimbra_dnd.zip installation failed

  1. #1
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    89
    Rep Power
    10

    Default [SOLVED] com_zimbra_dnd.zip installation failed

    If I try to install com_zimbra_dnd.zip on the server with the admin client I get an error saying that the deployment failed.

    on the Server I get the following message:
    Code:
    2010-08-24 14:43:25,490 INFO  [btpool0-47://mail.fqn:7071/service/upload?fmt=raw] [ip=xxx.xxx.xxx.xxx;ua=Jakarta Commons-HttpClient/3.0;] mailbox - FileUploadServlet received Upload: { accountId=e0fafd89-1360-11d9-8661-000a95d98ef2, time=Tue Aug 24 14:43:25 CEST 2010, uploadId=b8879a21-2b69-4611-a847-5bd4776f59e4:2d8a8c84-8315-457e-85b2-f68ed5b67513, com_zimbra_dnd.zip}
    2010-08-24 14:43:25,500 INFO  [btpool0-47://mail.fqn:7071/service/admin/soap/DeployZimletRequest] [name=zimbra;ip=xxx.xxx.xxx.xxx;] soap - DeployZimletRequest
    2010-08-24 14:43:25,501 INFO  [Thread-2415] [] zimlet - deploy
    java.io.FileNotFoundException: zimlet description not found: com_zimbra_dnd.xml
    	at com.zimbra.cs.zimlet.ZimletFile.initZimletDescription(ZimletFile.java:250)
    	at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletFile.java:206)
    	at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile.java:154)
    	at com.zimbra.cs.service.admin.DeployZimlet$DeployThread.run(DeployZimlet.java:98)
    	at java.lang.Thread.run(Thread.java:619)
    Any idea?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    What happens if you try and deploy it from the CLI ?

  3. #3
    Join Date
    Nov 2009
    Location
    Nantes, France
    Posts
    29
    Rep Power
    6

    Default

    zimlet description not found: com_zimbra_dnd.xml

    you get this error because the xml file in the zip doesn't have the good name. The solution is to unzip your extension, find the equivalent of the "com_zimbra_dnd.xml" and rename it.

    the name has to be the same between the xml file and the zip file
    Last edited by typiquement; 08-24-2010 at 09:06 AM.

  4. #4
    Join Date
    Nov 2005
    Location
    Germany
    Posts
    89
    Rep Power
    10

    Default

    This was not the reason. But it led me to the solution.

    The files in the zip had been in a directory. So i created a zip without the directory and it worked.

Similar Threads

  1. Replies: 8
    Last Post: 01-28-2010, 12:32 PM
  2. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  3. Problem with Mail Server - Need help!
    By joeleo in forum Installation
    Replies: 2
    Last Post: 03-04-2008, 12:03 PM
  4. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  5. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-18-2006, 12:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •