Results 1 to 3 of 3

Thread: id2entry.bdb failure

  1. #1
    Join Date
    Feb 2009
    Rep Power

    Default id2entry.bdb failure

    after we restarted our Zimbra server, we got the following error:

    Failed to start slapd.  Attempting debug start to determine error.
    hdb_db_open: database "": db_open(/opt/zimbra/data/ldap/hdb/db/id2entry.bdb) failed: Invalid argument (22).
    backend_startup_one (type=hdb, suffix=""): bi_db_open failed! (22)
    bdb_db_close: database "": alock_close failed
    First we tried the post zimbra LDAP crash when start. Using this we get Zimbra up and running, however our Zimbra information was outdated (from 5 months ago).

    Then we tried [SOLVED] slapd fail - (restore backup) and the post at the end of the same thread, but we are getting the same error.

    We looked at other threads like
    [SOLVED] LDAP / slapd - Database environment corrupt (Issue & Solution)
    [SOLVED] LDAP Problem - Zimbra won't start
    but the issue remains.

    Is there an option to fix i2entry.bdb without having to use a backup?

    Or could we use something at /opt/zimbra/bdb- to get things solved?

    Could we upgrade to the latest Zimbra version to try to solve the issue or should we first solve it before doing any upgrade?

    Thanks for any advice,

    p.s. We're using Zimbra 6.0.4
    Attached Images Attached Images

  2. #2
    Join Date
    Mar 2011
    Rep Power


    I'm stuck at the same point after a failed shutdown corrupted some files. Did you ever find a solution?

  3. #3
    Join Date
    Aug 2011
    Rep Power


    A year later and no solution?
    I have the same problem after full restore /opt/zimbra


Similar Threads

  1. LDAP crashing / repeated failure
    By geterdone in forum Administrators
    Replies: 3
    Last Post: 08-31-2010, 01:11 AM
  2. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  3. mysql not starting, sort of.
    By lhutton in forum Installation
    Replies: 6
    Last Post: 06-19-2009, 10:45 AM
  4. Replies: 4
    Last Post: 08-04-2008, 06:17 PM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts