Results 1 to 2 of 2

Thread: Recovering from disaster when suddenly...nothing happens

  1. #1
    Join Date
    Jun 2006
    Location
    Corvallis, Oregon, USA
    Posts
    100
    Rep Power
    9

    Default Recovering from disaster when suddenly...nothing happens

    Hi, I'm trying to write Disaster Recovery documentation that explains how to restore Zimbra on a system that has had Zimbra v3.1.4 Network Edition reinstalled. But when I get to the part about using zmrestoreoffline, nothing happens; it just returns to the command prompt with no errors, no nothing; it won't even show any help with zmrestoreoffline --help.

    I used the following links as references:
    http://wiki.zimbra.com/index.php?tit...dition_Restore
    http://www.zimbra.com/forums/showthread.php?t=3487

    Here are my steps so far:

    1. Install Red Hat EL 4.
    2. Install Zimbra v3.1.4 Network Edition.
    3. Stop the services that were automatially started during the installation: zmcontrol stop
    4. Copy the /opt/zimbra/backup directory from a backup server/tape/whatever.
    5. Update the permissions. I use the following script:
    Code:
    #!/bin/sh
    echo Updating permissions...
    /bin/chown -R root /opt/zimbra/backup
    /bin/chgrp -R zimbra /opt/zimbra/backup
    for x in $(ls /opt/zimbra/backup/sessions); do
        chmod 750 /opt/zimbra/backup/sessions/$x/session.dat;
    done
    /opt/zimbra/libexec/zmfixperms
    6. Restore the LDAP directory. Use zmrestoreldap -lbs to list the available sessions, and then zmrestoreldap -lb session to restore a session.
    7. Restore the system data with zmrestoreoffline -sys
    8. Restore the accounts from the latest full backup with zmrestoreoffline -rf -a all -c

    Since zmrestoreoffline does nothing, I tried zmrestore after starting the Zimbra services. But the accounts that have messages and folders won't restore:

    [zimbra@mail ~]$ zmrestore -rf -a all -c
    Error occurred during restore. Check logs for more details.
    The following accounts have not been restored:
    075q0.ag@mail.domain.edu
    randy@domain.com <--Alias account with messages & folders
    stevee@domain.com <--Alias account with messages & folders
    tn1rdsmo@mail.domain.edu
    torsten@domain.com <--Alias account with messages & folders


    Thanks for any additional info, suggestions and help.


  2. #2
    Join Date
    Sep 2005
    Posts
    57
    Rep Power
    10

    Default

    Hi, try repeating zmrestoreoffline with log level set to debug, by putting the following line in /opt/zimbra/conf/log4j.properties:

    log4j.logger.zimbra.backup=DEBUG

    Tomcat should be stopped prior to running zmrestoreoffline. ldap and mysql should be running.

    Any errors during restore will be logged to /opt/zimbra/log/zimbra.log, but not much detail on stdout/stderr.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Question about redo logs and disaster recovery
    By dlochart in forum Administrators
    Replies: 10
    Last Post: 08-12-2008, 03:40 AM
  2. Disaster Recovery on a Multi Server Configuration
    By dlochart in forum Administrators
    Replies: 2
    Last Post: 04-14-2007, 05:08 AM
  3. Manually recovering .msg files
    By czaveri in forum Administrators
    Replies: 2
    Last Post: 10-20-2006, 02:19 PM
  4. Disaster Recovery Steps for v3.1.4 Network Edition
    By ThorGoLucky in forum Administrators
    Replies: 0
    Last Post: 09-08-2006, 11:08 AM
  5. Network version disaster recovery steps.
    By dhallweb in forum Administrators
    Replies: 6
    Last Post: 04-06-2006, 08:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •