Results 1 to 2 of 2

Thread: Help with UNIX and Windows Accounts in Zimbra

  1. #1
    Join Date
    Jul 2008
    Posts
    7
    Rep Power
    7

    Default Help with UNIX and Windows Accounts in Zimbra

    Hi,

    I'm following the instructions here...

    UNIX and Windows Accounts in Zimbra LDAP and Zimbra Admin UI 6.0 - Zimbra :: Wiki

    The problem I'm running into is when you click on the "Posix Groups" and "Manage Samba Domains" in the samba admin web console, I see "No results found".

    The point where it starts talking about pam_ldap and nss_ldap is where the problems start. Everything ran smooth until I got there. I'm able to install (from apt) or compile from source. When apt didn't work, I tried to compile from source. I used the ldap.conf file like the wiki says to do. I configured samba using the smb.conf file, but nothing works.

    If anybody can give me a few hints on how to debug this or where to look on how to fix it, that would be great.

    Thanks!
    Mike

  2. #2
    Join Date
    Jul 2008
    Posts
    7
    Rep Power
    7

    Default

    For those with a similar problem... I monitored the /var/log/samba/smbd.log. This revealed that there was some issue with the password that was used. The password isn't the ldap root password, but yet the one that you set in the posixusers.ldif file.

    I changed it in /etc/ldap.secret, /etc/ldap.conf, and added it with smbpasswd -w <password>. After all this and a restart of smbd, problem solved.

Similar Threads

  1. UNIX nad Windows accounts..6.0 howto questions
    By alex3 in forum Installation
    Replies: 0
    Last Post: 12-16-2009, 03:59 AM
  2. Replies: 1
    Last Post: 10-13-2009, 11:52 AM
  3. Replies: 2
    Last Post: 02-13-2009, 02:13 AM
  4. Replies: 59
    Last Post: 12-05-2008, 10:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •