Results 1 to 6 of 6

Thread: How to switch from External Auth to Internal Auth with GAL Sync

Hybrid View

  1. #1
    Join Date
    Oct 2009
    Location
    Dublin, IRELAND
    Posts
    712
    Rep Power
    7

    Default How to switch from External Auth to Internal Auth with GAL Sync

    When I set up my zimbra server I configured it for External Authorization to an AD server.

    I have now come to realise what this means in terms of not being able to create temporary test email accounts, and not being able to log into email if the AD is unavailable for any reason.

    I believe that having local authorization with GAL Sync from the external AD to Zimbra would better suit my needs.

    Am I correct in this?

    Assuming a user updates their password on the network - how long would it take for that change to take affect in zimbra?

    Do password changes go both ways? If user changed their zimbra password - would it update the AD password? Or it it one-way from the AD to zimbra?

    Are there any gotchas associated with configuring it this way?

    Could anyone kindly give me a step-by-step howto guide for what I need to do to make the switch.

    Thanks in advance.

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Zimbra will not perform bi-directional password synchronisation. There is no reason why you cannot have a mixture of local or AD authentication. If AD is not available and you have set zimbraAuthFallbackToLocal to be TRUE then it will look at the local Zimbra password.

  3. #3
    Join Date
    Apr 2011
    Posts
    7
    Rep Power
    4

    Default

    I enabled zimbraAuthFallbackToLocal to be TRUE.
    How can I change or set a local password to user?

    Edit:
    I found it.
    zmprov sp user@domain.com PASSWORD

    But is it possible to change it in webadmin?
    Last edited by kontrabant; 08-03-2011 at 04:51 AM.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by kontrabant View Post
    I enabled zimbraAuthFallbackToLocal to be TRUE.
    How can I change or set a local password to user?
    Go to the Admin UI or use zmprov.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Apr 2011
    Posts
    7
    Rep Power
    4

    Default

    In Admin UI I have "change password" function disabled since i've setup
    Zimbra to use external auth.

  6. #6
    Join Date
    Mar 2010
    Location
    The Netherlands
    Posts
    23
    Rep Power
    5

    Default

    Quote Originally Posted by kontrabant View Post
    In Admin UI I have "change password" function disabled since i've setup
    Zimbra to use external auth.
    We have noticed the same behaviour and as far as I can tell this has been introduced with Zimbra 7. I presume this is intended behaviour?

    But in case you set zimbraAuthFallbackToLocal to TRUE (which we have for a number of domains) it is still not possible to change or set a password for an account using the Admin UI. That seems more like a bug to me.

Similar Threads

  1. External LDAP auth works, but External GAL doesn't
    By juniper in forum Administrators
    Replies: 0
    Last Post: 02-23-2010, 02:27 PM
  2. Zimbra GAL and GALSync Questions Since Upgrading to 6.0
    By Chewie71 in forum Administrators
    Replies: 2
    Last Post: 01-13-2010, 12:31 PM
  3. Switching from Internal Auth to External Active Directory
    By MindexAdmin in forum Installation
    Replies: 5
    Last Post: 07-19-2007, 12:14 PM
  4. Calendar GAL won't switch from Both to Internal
    By Vimm in forum Administrators
    Replies: 0
    Last Post: 04-13-2007, 01:35 PM
  5. internal and external GAL
    By chh in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 10-26-2006, 08:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •