Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Updating your license

  1. #1
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default Updating your license

    Hi,

    Existing multi-server platform. License was updated to reflect more account capacity. Installed license into zimbra admin console with no problems. Do I have to restart all the zimbra services zmcontrol stop;zmcontrol start on all my boxes for the license to go into affect? I did do a search on the forums and google for this information. Nothing was ever mentioned. Someone in these forums must know the answer to this question.

    Thank you in advance.
    Last edited by sae65; 09-08-2010 at 03:05 PM.

  2. #2
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    does the admin interface relect your updated mailbox count? It should be in the Global Settings -> License tab

  3. #3
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    Yes, it sure does. It did upon installing it. However the old administrator which left our university stated this morning that he had to restart the mail stores. But this evening when we finally past what we previously were licensed . We had reports of two outlook users that got a "expired license" error. The license clearly shows it is not expired. And as the license is what gives access to those premium features it made me wonder if all the zimbra services had to be restarted.

  4. #4
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

    Default

    i would think you'd be fine then. the only time i've seen issues with license not updating without a restart is there used to be a bug where deleted accounts didn't apply to the license count without a mailbox restart. i can't remember when that was fixed but i'm pretty sure it was because i noticed my own license count go down today when i deleted a bunch of accounts.

  5. #5
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    Interesting, deleted accounts do not reduce our total count. Only through a mailstore restart does it show up properly. But i'm on Zimbra 5.0.24, perhaps zimbra 5 never got rid of that bug.

  6. #6
    Join Date
    Jul 2007
    Location
    Baltimore
    Posts
    1,649
    Rep Power
    11

  7. #7
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    Restarting the servers.....it appears. Thank you for your correspondence. I never gave it much thought until this issue.

  8. #8
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    I've had to restart mailboxd on each of the other servers in a multi-server setup in the past to get the license to update. You can run 'zmlicense -p' on any of the servers you're not sure about to see what they're using.

    As for the user count, it should go down after a timeout I thought. The timeouts are lower as the number of users gets close to the limit.

  9. #9
    Join Date
    Mar 2009
    Posts
    46
    Rep Power
    6

    Default

    Last night I restarted all of our zimbra system. All of our mailstores had been restarted after the license changout but when some outlook users were getting "expired license" it seemed the old license was being cached somewhere else. So down the system went during the night hours. I will give that command a lookover as that would have been helpful in finding out where the culprit was hiding.

  10. #10
    Join Date
    Apr 2009
    Location
    Tokyo
    Posts
    28
    Rep Power
    6

    Default

    We'd like to know about this issue as well.
    Do we have to restart all stores to update license count?
    Or do we have to also restart ldap server and other servers?

Similar Threads

  1. Outlook conector say server license is expired
    By ajazevedo in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 09-08-2010, 02:01 PM
  2. Replies: 11
    Last Post: 06-22-2009, 06:05 AM
  3. migrate20070809-Signatures.pl?
    By j.mc in forum Installation
    Replies: 4
    Last Post: 06-11-2008, 09:52 AM
  4. postfix build error while building Zimbra source
    By anuradha_mihsra in forum Developers
    Replies: 6
    Last Post: 07-19-2007, 10:22 AM
  5. Error updating license after upgrading to latest patch
    By PureBrand in forum Installation
    Replies: 5
    Last Post: 05-03-2007, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •