Results 1 to 2 of 2

Thread: Upgrade issues ... upgrade failed without indication

Hybrid View

  1. #1
    Join Date
    May 2009
    Posts
    7
    Rep Power
    6

    Default Upgrade issues ... upgrade failed without indication

    zimbra is really pissing me off these days ...

    i am currently on
    Code:
    Release 6.0.4_GA_2213.DEBIAN5_64 DEBIAN5_64 FOSS edition.
    tried to upgrade to latest version a few days ago. didn't work. so i restored my backup. today i was trying to update to 6.0.5. identical behaviour to the upgrade a few days ago to 6.0.8.

    upgrade process:

    everything fine until:
    Code:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Operations logged to /tmp/zmsetup.09172010-224715.log
    Upgrading from  to 6.0.5_GA_2213
    Stopping zimbra services...done.
    Verifying /opt/zimbra/conf/my.cnf
    Starting mysql...done.
    I can't upgrade version 
    
    UPGRADE FAILED - exiting.
    so i looked into /tmp/zmsetup.log
    Code:
    Fri Sep 17 22:47:15 2010 Upgrading from  to 6.0.5_GA_2213
    Fri Sep 17 22:47:16 2010 Stopping zimbra services...
    Fri Sep 17 22:47:16 2010 *** Running as zimbra user: /opt/zimbra/bin/zmcontrol stop
    Host mail.filan.eu
            Stopping stats...Done.
            Stopping mta...Done.
            Stopping spell...Done.
            Stopping snmp...Done.
            Stopping archiving...Done.
            Stopping antivirus...Done.
            Stopping antispam...Done.
            Stopping imapproxy...Done.
            Stopping memcached...Done.
            Stopping mailbox...Done.
            Stopping logger...Done.
            Stopping ldap...Done.
    Fri Sep 17 22:47:23 2010 done.
    Fri Sep 17 22:47:23 2010 Verifying /opt/zimbra/conf/my.cnf
    Fri Sep 17 22:47:23 2010 Starting mysql...
    Fri Sep 17 22:47:23 2010 *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
    Starting mysqld...done.
    Fri Sep 17 22:47:34 2010 done.
    Fri Sep 17 22:47:35 2010 I can't upgrade version 
    
    Fri Sep 17 22:47:35 2010 UPGRADE FAILED - exiting.
    and /tmp/install.log.LATEST
    Code:
    Unpacking zimbra-mta (from .../zimbra-mta_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-mta (6.0.5_GA_2213.DEBIAN5_64) ...
    Selecting previously deselected package zimbra-snmp.
    (Reading database ... 29294 files and directories currently installed.)
    Unpacking zimbra-snmp (from .../zimbra-snmp_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-snmp (6.0.5_GA_2213.DEBIAN5_64) ...
    ln: creating symbolic link `/opt/zimbra/net-snmp/net-snmp-5.5': File exists
    Selecting previously deselected package zimbra-store.
    (Reading database ... 29863 files and directories currently installed.)
    Unpacking zimbra-store (from .../zimbra-store_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-store (6.0.5_GA_2213.DEBIAN5_64) ...
    ln -s /opt/zimbra/jetty-6.1.15 /opt/zimbra/jetty
    Selecting previously deselected package zimbra-apache.
    (Reading database ... 51660 files and directories currently installed.)
    Unpacking zimbra-apache (from .../zimbra-apache_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-apache (6.0.5_GA_2213.DEBIAN5_64) ...
    Selecting previously deselected package zimbra-spell.
    (Reading database ... 52907 files and directories currently installed.)
    Unpacking zimbra-spell (from .../zimbra-spell_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-spell (6.0.5_GA_2213.DEBIAN5_64) ...
    Selecting previously deselected package zimbra-memcached.
    (Reading database ... 53292 files and directories currently installed.)
    Unpacking zimbra-memcached (from .../zimbra-memcached_6.0.5_GA_2213.DEBIAN5_64_amd64.deb) ...
    Setting up zimbra-memcached (6.0.5_GA_2213.DEBIAN5_64) ...
    no errors at all.

    so i tried to start zimbra.

    Code:
    zmcontrol start
    Host mail.filan.eu
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting antispam...Done.
            Starting antivirus...Done.
            Starting snmp...Done.
            Starting mta...Done.
            Starting stats...Done.
    everything fine.

    i wish.

    Code:
    zmcontrol status
    Host mail.filan.eu
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Running
            mailbox                 Stopped
                    zmmailboxdctl is not running.
            mta                     Running
            snmp                    Running
            stats                   Running
    output /opt/zimbra/log/mailbox.log
    Code:
    tail -20 /opt/zimbra/log/mailbox.log
    2010-09-17 23:10:52,057 INFO  [main] [] soap - Adding service IMService to SoapServlet
    2010-09-17 23:10:52,062 INFO  [main] [] misc - version=6.0.5_GA_2213.DEBIAN5_64 release=20100131185825 builddate=20100131-1900 buildhost=build32.lab.zimbra.com
    2010-09-17 23:10:52,063 INFO  [main] [] misc - LANG environment is set to: C
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.home=/opt/zimbra/jdk1.6.0_16/jre
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.runtime.version=1.6.0_16-b01
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.version=1.6.0_16
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.vm.info=mixed mode
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.vm.name=Java HotSpot(TM) 64-Bit Server VM
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property java.vm.version=14.2-b01
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property os.arch=amd64
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property os.name=Linux
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property os.version=2.6.26-2-amd64
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property sun.arch.data.model=64
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property sun.cpu.endian=little
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property sun.cpu.isalist=
    2010-09-17 23:10:52,063 INFO  [main] [] misc - System property sun.os.patch.level=unknown
    2010-09-17 23:10:52,083 INFO  [main] [] system - Setting mysql connector property: maxActive=100
    2010-09-17 23:10:52,093 INFO  [main] [] system - Setting mysql connector property: maxActive=100
    2010-09-17 23:10:52,881 ERROR [main] [] Versions - DB Version Mismatch: ours="64" from DB="63"
    2010-09-17 23:10:52,881 FATAL [main] [] system - Data version mismatch.  Reinitialize or upgrade the backend data store.
    i looked into any other logfile mentioned here : Log Files - Zimbra :: Wiki (by the way, this page needs to bee updated or am i not finding the latest real "log files" page

    so the only error i was able to find in any logfile is this one

    Code:
    2010-09-17 23:10:52,881 ERROR [main] [] Versions - DB Version Mismatch: ours="64" from DB="63"
    2010-09-17 23:10:52,881 FATAL [main] [] system - Data version mismatch.  Reinitialize or upgrade the backend data store.
    but there is no solution for that. i did find some threads mentioning this line of code, but no solution.

    what am i doing wrong people?? and why isnt there a sign for my wrongness?? PLEASE HELP

  2. #2
    Join Date
    May 2009
    Posts
    7
    Rep Power
    6

    Default

    so i kinda fixed it, but am not sure if it was a good idea

    regarding this one
    Code:
    2010-09-17 23:10:52,881 ERROR [main] [] Versions - DB Version Mismatch: ours="64" from DB="63"
    2010-09-17 23:10:52,881 FATAL [main] [] system - Data version mismatch.  Reinitialize or upgrade the backend data store.
    i connected to the zimbra mysql db, looked into the config-table and change the value from 63 to 64

    the re-upgrade to 6.0.5 failed again with no information why, but i could start zimbra and everything worked so far. so i upgraded to 6.0.8, again failed upgrade but zimbra worked again, and zmcontrol -v shows 6.0.8

    i've got one javascript error in the admin gui, that's it. everything else seems to work perfectly.

Similar Threads

  1. Install zcs 6.0.8 on SLESS 10 32 bits
    By samesisa in forum Installation
    Replies: 2
    Last Post: 10-21-2010, 03:16 PM
  2. Replies: 8
    Last Post: 01-28-2010, 12:32 PM
  3. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  4. My Zimbra server down ... please help :)
    By frankb in forum Administrators
    Replies: 2
    Last Post: 12-12-2007, 11:29 AM
  5. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •