Results 1 to 7 of 7

Thread: [SOLVED] Upgrade to 6.0.8 failed

  1. #1
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    5

    Default [SOLVED] Upgrade to 6.0.8 failed

    I have tried upgrading zimbra from 6.0.7 to 6.0.8 and got the following error while upgradation

    Can't load '/opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so' for module Data::UUID: /opt/zimbra/zimbramon/lib/i386-linux-thread-multi/auto/Data/UUID/UUID.so: requires glibc 2.5 or later dynamic linker at /usr/lib/perl5/5.8.5/i386-linux-thread-multi/DynaLoader.pm line 230.
    at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/Zimbra/Mon/Logger.pm line 22.
    Compilation failed in require at /opt/zimbra/bin/zmcontrol line 27.
    BEGIN failed--compilation aborted at /opt/zimbra/bin/zmcontrol line 27.

    Any ideas?

  2. #2
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Looks like a missing dependency. Do you have the upgrade log (/tmp/zmsetup.log)? Especially the beginning, where dependencies are checked may be interesting.

    Only comparable issues I can find on the forums are when ZCS installer for RHEL / CentOS 5 is installed on a RHEL / CentOS 4 system.

  3. #3
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    5

    Default

    If thats the case, what is the recovery procedure?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    How about details of the contents of your install log file? Did you actually install the correct version of the Zimbra binary for your platform?

    Quote Originally Posted by Saturdays View Post
    If thats the case, what is the recovery procedure?
    You do have a Disaster Recovery plan, don't you? If not: Search results for "disaster recovery" - Zimbra :: Wiki
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Without any details (please attach the complete /tmp/zmsetup.log file) there's not much anyone can do.

  6. #6
    Join Date
    Nov 2009
    Location
    Ljubljana, Slovenia
    Posts
    268
    Rep Power
    6

    Default

    Also, double check that you downloaded correct Zimbra package for your system! Once I spent all night troubleshooting the *wrong* Zimbra install...

  7. #7
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    5

    Default

    sorry for the late reply.... I was busy with ma work.... I messed up the installation with the wrong version.

    It got all fixed, I had to remove the new installation that was corrupt after copying the conf/ssl/etc.... and re-installed with new version, restored all the accounts (only about 12 accounts in this server, thank Lord for tat). They all worked fine. I understood the meaning of BACKUP now.

    This can be marked as solved.

Similar Threads

  1. Install zcs 6.0.8 on SLESS 10 32 bits
    By samesisa in forum Installation
    Replies: 2
    Last Post: 10-21-2010, 03:16 PM
  2. Replies: 3
    Last Post: 08-31-2010, 02:41 AM
  3. Replies: 8
    Last Post: 01-28-2010, 12:32 PM
  4. Help!!! Moving ZCS does not work!
    By ASebestian in forum Migration
    Replies: 7
    Last Post: 02-12-2009, 06:06 PM
  5. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •