Results 1 to 3 of 3

Thread: ZCS6 Posix Account Zimlet

  1. #1
    Join Date
    May 2008
    Location
    Des Moines, IA
    Posts
    89
    Rep Power
    7

    Default ZCS6 Posix Account Zimlet

    I'm doing the ZCS6/Samba thing and I caught a little problem...

    During account creation, the Posix Account screen allows you to pull-down for Posix group and loginShell.

    Posix group: When you select a posix group from the drop-down the gid number is not auto-populated in the gidNumber field.
    *If you were to click the Next button anyway, then the Back button, it does get populated.

    loginShell: This drop-down does not list the shells: /bin/bash,/bin/sh,/bin/false

    I've searched and found loginShell greps from /opt/zimbra/data/ldap/config/cn=config/cn=schema/cn={10}nis.ldif

    These are the settings that get deployed:
    # cat /tmp/zimlets_posix/config_template.xml
    <zimletConfig name="zimbra_posixaccount" version="6.0.2">
    <global>
    <property name="loginShells">/bin/bash,/bin/sh,/bin/false</property>
    <property name="homePath">/export/homes/%u</property>
    <property name="gidBase">10000</property>
    <property name="uidBase">10000</property>
    <property name="ldapSuffix">dc=domain,dc=tld</property>
    <property name="ldapGroupSuffix">ou=groups</property>
    </global>
    </zimletConfig>

    All fairly straight-forward.

    I have 4 shells going on a second 22" monitor to tail -f various logs and I don't show any zimbra-related errors during account creation. I'm not sure where to go after this.

    Has anyone seen and fixed this before?

    TIA, TT
    Last edited by todd_dsm; 09-28-2010 at 07:55 AM. Reason: scrubbed the domain

  2. #2
    Join Date
    Sep 2005
    Location
    Tucson - San Francisco - Moscow
    Posts
    127
    Rep Power
    10

    Default

    Quote Originally Posted by todd_dsm View Post

    Posix group: When you select a posix group from the drop-down the gid number is not auto-populated in the gidNumber field.
    *If you were to click the Next button anyway, then the Back button, it does get populated.
    Bug #43530 going to be fixed in 7.0

    loginShell: This drop-down does not list the shells: /bin/bash,/bin/sh,/bin/false
    Does it list anything at all? Can you attach a screenshot?
    Bugzilla - Wiki - Downloads - Before posting... Search!
    P.S.: don't forget to vote on this bug
    add Samba LDAP entries to Exchange Migration Tool

  3. #3
    Join Date
    May 2008
    Location
    Des Moines, IA
    Posts
    89
    Rep Power
    7

    Default more details...

    Greg,

    If the Posix Group drop-down has a bug - no worries. It doesn't hold up a thing; the correct gid is still associated with the user via drop-down selection.

    loginShell...
    Does it list anything at all? Can you attach a screenshot?
    Nada. I could send you a screen shot but it would be a screen shot of nothing :P

    I can describe it to you:
    When clicked or unclicked, visually the loginShell drop-down looks the same - no change at all. Not like it's attempting to give you an empty list - more like it's not doing anything at all.

    OK, here's the screen shot anyway. Here, I've created a new posix group called 'whatever' and a new user 'user7' and assigned the new user to the whatever group. Also, I'm currently clicked on the loginShell drop-down while taking the screen shot with the other hand - whew!
    Attached Files Attached Files

Similar Threads

  1. Replies: 6
    Last Post: 03-05-2010, 01:13 AM
  2. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  3. Samba and POSIX undeploy problem
    By catnipper in forum Zimlets
    Replies: 0
    Last Post: 09-02-2009, 11:51 AM
  4. Replies: 1
    Last Post: 10-02-2007, 01:30 AM
  5. Using Zimlet to add zimbra account
    By dzed in forum Zimlets
    Replies: 2
    Last Post: 05-05-2006, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •