Results 1 to 3 of 3

Thread: Changing listening ports...

  1. #1
    Join Date
    Sep 2010
    Posts
    12
    Rep Power
    5

    Default Changing listening ports...

    Hi,

    now that my server is running, I wanted to switch the listening ports to the classical ones... I tried:
    Code:
    $ zmprov ms domain.com zimbraMailSSLPort 443
    ERROR: service.INVALID_REQUEST (invalid request: port 443 conflict between zimbraMailSSLPort and zimbraMailSSLProxyPort on server domain.com)
    I checked the ports and here's what I got...
    Code:
    $ zmprov gacf | grep Port
    ...
    zimbraMailPort: 80
    zimbraMailProxyPort: 0
    zimbraMailSSLPort: 0
    zimbraMailSSLProxyPort: 0
    ...
    So I gave the proxy a "fake" port and then I could change the ssl port (and ran into connection refused)...
    Code:
    zmprov ms domain.com zimbraMailSSLProxyPort 9443
    $ zmprov ms domain.com zimbraMailSSLPort 443
    $ zmprov ms domain.com zimbraMailSSLProxyPort 0   
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    The strange thing is that the ports are still listed as being set to 0 from gacf...
    Where can I get the real values?

    Thx,
    JD

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    gacf is global but your modifying the server level, let's just deal with gs and ms only:

    Alright so:
    zmprov -l ms server.domain.com zimbraMailPort 80 zimbraMailProxyPort 0 zimbraMailSSLPort 443 zimbraMailSSLProxyPort 0
    zmprov -l gs server.domain.com | grep zimbraMailPort
    zmcontrol restart
    (note first command is on one line/that's an L ell for provisioning via LDAP because you've messed up mailboxd/also proxy isn't typical for single server installs)

    If you want to change the http port to 443 go for it, but that doesn't magically add https/ssl, you should do like:
    zmtlsctl redirect
    zmcontrol restart
    CLI zmtlsctl to set Web Server Mode - Zimbra :: Wiki

  3. #3
    Join Date
    Sep 2010
    Posts
    12
    Rep Power
    5

    Default

    Quote Originally Posted by mmorse View Post
    gacf is global but your modifying the server level, let's just deal with gs and ms only
    Ah, thx for the info!
    gs indeed show me the correct values (the proxy is not activated btw).
    Code:
    zimbraMailPort: 8080
    zimbraMailProxyPort: 80
    zimbraMailSSLPort: 8443
    zimbraMailSSLProxyPort: 9443
    The -l ldap option is also quite helpful.
    Is there a reason why it is not the standard as opposed to http?

    Quote Originally Posted by mmorse View Post
    If you want to change the http port to 443 go for it, but that doesn't magically add https/ssl, you should do like:
    I installed Zimbra in redirect from the start, but on non standard ports (8080 => 8443).
    So, just changing the ports should work, no?

    Thx a lot,
    JD

Similar Threads

  1. Clients stopped receiving emails
    By egadinc in forum Administrators
    Replies: 16
    Last Post: 12-14-2009, 03:38 PM
  2. listening ports
    By Jimmystewpot in forum Installation
    Replies: 1
    Last Post: 03-24-2009, 05:06 AM
  3. [SOLVED] Changing HTTP ports
    By Jrtbloke in forum Installation
    Replies: 2
    Last Post: 01-09-2009, 11:33 AM
  4. Cannot login as admin after install
    By elesouef in forum Installation
    Replies: 23
    Last Post: 02-13-2007, 09:06 AM
  5. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •