About 2 weeks ago (09/17) one of my users informed me that an important email he sent had not yet arrived at it's destination. When I heard this, I checked and found it sitting in the queue with the error:

(lost connection with[] while sending end of data -- message may be sent more than once)

I also noticed a number of other messages were stuck in the deferred queue with this message. I read a number of things both here on the forums and on other sites and could not find any silver bullet to fixing this.

I finally found one message from a user who said turning off Antispam solved this issue for him. I tried that and lo and behold, it worked. BUT, this also meant LOTS of spam that was previously not getting through started getting through.

I initially chalked this up to a bad RBL or something on the day of this issue and figured I could wait a few days and maybe things would be better again. I have tried just that a number of times in the last few days and still a number of emails (not all, just some) get stuck in the queue with this same error.

I am running ZCS Network Edition 6.0.8 and have been since the end of August, so no upgrade or changes to the system have been done recently on a system level.

I can provide whatever config files you need, just let me know what you would like to see.