Results 1 to 5 of 5

Thread: Help set up Autocomplete Search Gal on the field title.

Hybrid View

  1. #1
    Join Date
    Mar 2010
    Posts
    6
    Rep Power
    5

    Default Help set up Autocomplete Search Gal on the field title.

    Good afternoon.

    Please help to configure the GAL Autocomplete search field title.

    Installed:
    Code:
     
    zmcontrol-v " 
    Release 6.0.8_GA_2661.UBUNTU10_64 UBUNTU10_64 FOSS edition.
    GAL is set to sync with ldap.
    Synchronization settings Gal were as follows:
    Code:
     
    Gal mode - both 
    Server type - Ldap 
    Ldap Filter - (&(|( cn =*% s *) (sn =*% s *) (gn =*% s *)) (mail =* @ domail.com) 
    Autocomplete filter - (| (cn =% s *) (sn =% s *) (gn =% s *) (mail =% s *)) 
    Ldap search base - ou = active, dc = mail, dc = domain, dc = com
    With these settings, in Gal, I saw all the necessary users.
    Also from Ldap unloaded into Zimbra attributes (title, telephonenumber ...)

    I want to search for users in Gal on the field title.
    But setting Autocomplete filter as does not affect the search.
    I tried to specify a filter (| (cn =% s *) (sn =% s *) (gn =% s *) (mail =% s *) (title =*% s *))

    Tell me please what is needed for Autocomplete filter when configuring the external Gal?

    If I do a search on the field title in the user contact galsync then everything works fine.
    But I would like what would such a search also works in Gal.
    In such settings, searching for title field does not work if I write another letter (I type in the To, or a global search.

    Sorry for my English.
    Last edited by kharkov_max; 10-01-2010 at 11:44 PM.

  2. #2
    Join Date
    Mar 2010
    Posts
    6
    Rep Power
    5

    Default

    Help me
    UP

  3. #3
    Join Date
    Apr 2011
    Posts
    1
    Rep Power
    4

    Default

    Quote Originally Posted by kharkov_max View Post
    Good afternoon.

    Please help to configure the GAL Autocomplete search field title.

    Installed:
    Code:
     
    zmcontrol-v " 
    Release 6.0.8_GA_2661.UBUNTU10_64 UBUNTU10_64 FOSS edition.
    GAL is set to sync with ldap.
    Synchronization settings Gal were as follows:
    Code:
     
    Gal mode - both 
    Server type - Ldap 
    Ldap Filter - (&(|( cn =*% s *) (sn =*% s *) (gn =*% s *)) (mail =* @ domail.com) 
    Autocomplete filter - (| (cn =% s *) (sn =% s *) (gn =% s *) (mail =% s *)) 
    Ldap search base - ou = active, dc = mail, dc = domain, dc = com
    With these settings, in Gal, I saw all the necessary users.
    Also from Ldap unloaded into Zimbra attributes (title, telephonenumber ...)

    I want to search for users in Gal on the field title.
    But setting Autocomplete filter as does not affect the search.
    I tried to specify a filter (| (cn =% s *) (sn =% s *) (gn =% s *) (mail =% s *) (title =*% s *))

    Tell me please what is needed for Autocomplete filter when configuring the external Gal?

    If I do a search on the field title in the user contact galsync then everything works fine.
    But I would like what would such a search also works in Gal.
    In such settings, searching for title field does not work if I write another letter (I type in the To, or a global search.

    Sorry for my English.
    Man, did you ever figure out how to do this?
    I've been struggling with it for two days.
    I already modified the attribute "zimbraGalLdapFilterDef: externalLdapAutoComplete:" but Zimbra completely ignores it. It only seems to use the default '(|(cn=%s*)(sn=%s*)(gn=%s*)(mail=%s*))'.

  4. #4
    Join Date
    Sep 2012
    Posts
    3
    Rep Power
    3

    Default

    Hi,
    I'm using
    zmcontrol -v
    Release 7.2.0_GA_2669.UBUNTU10_64 UBUNTU10_64 NETWORK edition.
    I would like to restrict answers when auto-completing because our GAL contains 20000 users, but i can't.
    Like gcarelli, i also tried to set the global attribute 'zimbraGalLdapFilterDef: externalLdapAutoComplete' without success.
    I believe '(|(cn=%s*)(sn=%s*)(gn=%s*)(mail=%s*))' is hard-coded somewhere...

    Someone already reached?

    Thanks a lot.

  5. #5
    Join Date
    Sep 2012
    Posts
    3
    Rep Power
    3

    Default

    I have solute my problem changing the value of the attribute zimbraGalSyncAccountBasedAutoCompleteEnabled to false.
    It's a COS or account attribute.
    This way, autocompletion request your LDAP server, so think about good indexing...

Similar Threads

  1. Replies: 2
    Last Post: 05-14-2009, 05:32 PM
  2. Replies: 2
    Last Post: 05-11-2009, 01:42 AM
  3. GAL search in Find Attendees
    By Vladimir in forum Administrators
    Replies: 0
    Last Post: 02-05-2009, 03:31 PM
  4. gal search issue
    By menonumesh in forum Administrators
    Replies: 1
    Last Post: 05-09-2007, 06:07 AM
  5. Replies: 1
    Last Post: 03-27-2007, 11:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •