I'm building an Active/Passive zimbra cluster with DRBD.

I have installed Zimbra on two nodes.
(installed one node, then switched drbd to the other, deleted /opt/zimbra. It was mounted from /dev/drbd1, and did another clean install on the 2nd node.)

the /etc/hosts file are the same on both nodes:
Code:
cat /etc/hosts
127.0.0.1       localhost
XXX.XXX.XXX.XX4 mydomain.net
XXX.XXX.XXX.XX3 mydomain.net Node01
XXX.XXX.XXX.XX2 mydomain.net Node02
I am using heartbeat to switch resources, that's why i have XXX.XXX.XXX.XX4 mydomain.net configured as a virtual ip.

MX records set up like this:
Code:
mydomain.net IN MX  0 mydomain.net
mydomain.net IN MX 10 Node01.mydomain.net
mydomain.net IN MX 20 Node02.mydomain.net
The problem when I switch nodes, (reboot Node01), DRBD mounts /opt but when I want to start zimbra from /etc/init.d/zimbra start, it wont start on the second node. It's working fine on node 1, but the 2nd does not.
I know I should put it as a start up into the /etc/heartbeat/haresources but at the moment I would like to see the system working manually. Once I can start it on Node02 I'll put into heartbeat to start it, but until that I would like to see it working.

the error I'm getting:
Code:
/etc/init.d/zimbra start
Host localhost
Unable to determine enabled services from ldap.
Why does this wants to go for localhost?? It has the virtual IP, and Zimbra was configured to use that.

Thanks for the help! I've been strugling with this for two days now.