I've been having this issue since I implemented ZCS, I've had a couple contractors look at this and all of them said they would rather have me switch to exchange. One even said they had this issue figured out, but to fix the issue it would open us up to spam attacks etc and it didn't fall in line with their best practices and procedures so I was submitted a gigantic invoice to switch to exchange.

Bottom line - I'm tasked with fixing this problem.

Issue:
Users cannot send or receive mail from/to any charter.net (chartermi.net etc) and one called dmoproperties.com.

It's a quirky problem, as I have a personal chartermi.net account and I'm able to receive emails from my company but not send from my company to my charter account. Other users complain they are not able to receive or send.

rDNS is properly configured, it is just these couple domains that I cannot get working. They have been whitelisted on zimbra, I'm able to send messages from my charter account to my company domain, and I've had a couple people here attempt to send mail to their charter accounts at home and this is what they are receiving, it is hit and miss whether the user receives a bounce back message. Company domain is not blacklisted either, I used mxtoolbox to verify.

Bounce back message, which sometimes you get, sometimes you don't:

Reporting-MTA: dns; mail.olmstedproducts.com
X-Postfix-Queue-ID: ADD0D21E147
X-Postfix-Sender: rfc822; xxxx@olmstedproducts.com
Arrival-Date: Tue, 19 Oct 2010 12:56:12 -0400 (EDT)

Final-Recipient: rfc822; xxx@chartermi.net
Original-Recipient: rfc822;xxx@chartermi.net
Action: failed
Status: 5.2.0
Remote-MTA: dns; ib1.charter.net
Diagnostic-Code: smtp; 550 5.2.0 Lgkn1f07c4b6Wu404gkotA you are not allowed to
send mail to <xxx@chartermi.net> E9210
ZCS verision is in my profile

Any tips?