Results 1 to 6 of 6

Thread: Configure Zimbra to use external relay for specific domains

  1. #1
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Smile Configure Zimbra to use external relay for specific domains

    Hi,
    I am running Zimbra 5.0.18 GA 3011 on an Ubuntu server with an internal IP address. I have a split brained dns server installed on the server.

    When our users send an email to a particular domain say example.com, our server gives them the message that the mailserver.example.com said 554 Transaction
    Failed Spam Message not queued. (in reply to end of DATA command)
    I've contacted the postmaster@example.com and he said that the message was released. However, we continually get this bounced mail when we send mail to example.com.

    So, now what I want to do is to use an external smarthost to relay mail only for example.com. I want some guidance on how to configure zimbra to relay mail for example.com to the smart host. The smart host requires authentication.

    I was also thinking of placing an A record (or do I need a MX record) for mail.example.com giving it the IP address of the smarthost in our splitbrained internal dns server. I think doing this will tell my zimbra server to connect to the smarthost for mail addressed to example.com. With this set up, will the smarthost forward the email to example.com or reject the mail because of unknown user.

    Further, I tried to telnet to mail.example.com on port 25 from the zimbra server and it permitted it to relay mail only for users in the domain example.com.

    I am a newbie with Zimbra and is more knowledgeable with Lotus Notes where I can add relays for particular domains by just modifying smtp server documents.

    Appreciate your help.

    Thanks,

    emram

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    Quote Originally Posted by phoenix View Post
    Thanks for your reply. How about setting up the smarthost authentication?

  4. #4
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    This is correction to my initial post. In my initial post, I mentioned that I can telnet to the mail server of example.com and that I can relay mail to users in example.com.

    After entering data on the telnet session, I got the 554 message as shown below:

    554 Transaction Failed Spam Message not queued.
    Connection closed by foreign host.

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by emram View Post
    Thanks for your reply. How about setting up the smarthost authentication?
    If you mean outbound SMTP authentication the search the wiki for the word 'authentication'.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    Quote Originally Posted by phoenix View Post
    I read that wiki and was considering it and then I read Outgoing SMTP Authentication - Zimbra :: Wiki .
    In the latter wiki, it talks about setting a relay host to route all mail.

    What I want is to route only for the particular domain to the external smart host which was shown in the first wiki.

    So, should I just follow the first wiki and then skipp the setting a relay host and go straight to enabling smtp authentication?

Similar Threads

  1. My Zimbra Server crashed this morning...
    By glitch23 in forum Administrators
    Replies: 3
    Last Post: 04-07-2008, 01:28 PM
  2. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  3. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 02:30 PM
  5. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •