Results 1 to 8 of 8

Thread: Can't connect to Zimbra with iPad/iPhone over Exchange protocol

  1. #1
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default Can't connect to Zimbra with iPad/iPhone over Exchange protocol

    Dear,

    Since a few weeks we have a Zimbra server running, first we used the OpenSource Comunity version, yesterday we upgraded the server to the Network edition to have more sync functions.

    On this moment we can't connect to the Zimbra server over the Exchange protocol with for example a iPad / iPhone. We used this tutorial to find out how it works:
    Zimbra - iPhone

    But we have the following problems when we try to connect with our iphone / ipad.

    - The certificate from "autodiscover.domain.com" for account "username@domain.com" could not be verified. (we can accept this manually)
    - Unable to verify account information

    We can't connect to mailboxes on the Zimbra server!

    Our Zimbra server is colocated in a Datacenter and we connect remotely from our office to the server.

    Our firewall is configured well, the ports that are enabled are:
    SMTP 25 tcp
    HTTP 80 tcp
    POP3 110 tcp
    IMAP 143 tcp
    LDAP 389 tcp
    HTTPS 443 tcp
    SMTPS 465 tcp
    IMAPS 993 tcp
    POP3S 995 tcp
    (Admin Interface) 7071 tcp

    What could be the problem?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by lumix1991 View Post
    But we have the following problems when we try to connect with our iphone / ipad.

    - The certificate from "autodiscover.domain.com" for account "username@domain.com" could not be verified. (we can accept this manually)
    - Unable to verify account information
    Did you accept the Certificate manually?

    Quote Originally Posted by lumix1991 View Post
    We can't connect to mailboxes on the Zimbra server!
    You mean via Activesync or something else? Is the Mobile feature actually enabled (you can check in the Admin UI)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    Quote Originally Posted by phoenix View Post
    Did you accept the Certificate manually?

    You mean via Activesync or something else? Is the Mobile feature actually enabled (you can check in the Admin UI)?
    Yes, i checked the option in the admin panel to allow the user to connect with mobile sync. Also we accepted the autodiscover certificate manually and after that we will see the "Unable to verify account information."

  4. #4
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    I never use autodiscover. Some devices try to use it, but Zimbra doesn't have it as far as I can tell. (Would appreciate correction if I am wrong about this.)

    I think this is covered in step 4 of the instructions you refer to. You also don't need to have anything in the Domain field.

    Just ignore autodiscovery and use the "full" account info screen.

    Email: your full email address
    Server: your server's FQDN
    Username: your full email address
    Password: your password

  5. #5
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    Quote Originally Posted by ewilen View Post
    I never use autodiscover. Some devices try to use it, but Zimbra doesn't have it as far as I can tell. (Would appreciate correction if I am wrong about this.)

    I think this is covered in step 4 of the instructions you refer to. You also don't need to have anything in the Domain field.

    Just ignore autodiscovery and use the "full" account info screen.

    Email: your full email address
    Server: your server's FQDN
    Username: your full email address
    Password: your password
    Yes, that is what i did but it won't work. Is it something with firewall settings of the server? it looks like the cients can't have a connection to the server. When we connect with IMAP / POP it works perfect. But when we like to use the exchange protocol we will stuck there.

  6. #6
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    Do you have a self-signed cert on ZCS? Not sure if it matters, but might as well find out.

    I don't think it has anything to do with firewall settings--as long as you can reach ports 80 and 443 on the server, it should work. Of course you do want to make sure the server itself isn't blocking those ports with a firewall. Can you get to it via web interface?

    I remain puzzled at your getting an autodiscover cert at all. I don't think you should be getting the message to accept the cert. Check DNS to see if autodiscover.domain.com exists, and if it does, ask yourself why it does and whether you can remove it.

  7. #7
    Join Date
    Oct 2010
    Posts
    4
    Rep Power
    4

    Default

    Quote Originally Posted by ewilen View Post
    Do you have a self-signed cert on ZCS? Not sure if it matters, but might as well find out.

    I don't think it has anything to do with firewall settings--as long as you can reach ports 80 and 443 on the server, it should work. Of course you do want to make sure the server itself isn't blocking those ports with a firewall. Can you get to it via web interface?

    I remain puzzled at your getting an autodiscover cert at all. I don't think you should be getting the message to accept the cert. Check DNS to see if autodiscover.domain.com exists, and if it does, ask yourself why it does and whether you can remove it.
    Yes, currently we have a self sign certificate on our server. I just saw that my autodiscover.domain.com points to my domain root (where my website is running, there i have enabled a HTTPS certificate). I will create a autodiscover record at my domain, so that the client can't point to the SSL certificate that i use on my website. But this can't be doing something with the exchange verify problem i think?

  8. #8
    Join Date
    Oct 2008
    Posts
    31
    Rep Power
    7

    Default Mobile access

    Is the mobile access allowed in the account settings for the users you are trying to enable this for?

Similar Threads

  1. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  2. Replies: 31
    Last Post: 12-15-2007, 08:05 PM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 11:45 AM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •