Results 1 to 7 of 7

Thread: Zimbra 4 dies on reboot

Hybrid View

  1. #1
    Join Date
    Sep 2006
    Posts
    7
    Rep Power
    9

    Default Zimbra 4 dies on reboot

    Hi all,

    I have Zimbra 4 installed on an IBM eServer with a 2.8GHz P4 and 2GB of RAM running RHEL4.3 (Educational Licence). The machine has an 80GB SATA drive rigged to carry the system and two 160GB SATA disks connected as a RAID 1 array and mounted as /opt.

    I Installed Zimbra 4 and configured bind on the same machine to provide DNS as it was destined for our DMZ. Having got Zimbra up and running, we ran the Migration tool to draw the accounts off of our Exchange 5.5 NT Server which worked perfectley apart from 27 messages that were too large but that wasn't a problem. All in all the setup and migration were remarkably easy but having moved it into our server room, LDAP won't start. It really was a case of shutdown -h now, unplug, move to server room, plug in, switch on LDAP Failed and I can't find a reason. Given that it'd been running for 4 days without a hitch I can't see why shutting down and rebooting would hurt it.

    Anyway, diagnostic outputs below,

    Cheers and thanks for any help,

    Jools.

    --------- Output from zmcontrol start ------------

    [zimbra@zimbra bin]$ /opt/zimbra/bin/zmcontrol start
    Host zimbra.bordengrammar.kent.sch.uk
    Starting ldap...Done.
    FAILED
    ERROR - failed to start slapd

    --------------------------------------------------


    ------ End of /var/log/messages after start fails -----

    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/sda8, mp: /admins, tot: 52412, avail: 49665
    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/sda1, mp: /boot, tot: 183, avail: 157
    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/sda7, mp: /home, tot: 9389, avail: 8498
    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/md0, mp: /opt, tot: 150230, avail: 133882
    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/sda3, mp: /tmp, tot: 1406, avail: 1297
    Sep 15 10:50:02 zimbra zimbramon[6736]: 6736:info: 2006-09-15 10:50:01, DISK: zimbra.bordengrammar.kent.sch.uk: dev: /dev/sda6, mp: /usr, tot: 4695, avail: 2802
    Sep 15 10:50:02 zimbra zimbramon[6733]: 6733:info: 2006-09-15 10:50:01, QUEUE: 0 0
    Sep 15 10:50:06 zimbra zimbramon[6738]: 6738:info: 2006-09-15 10:50:01, STATUS: : Cannot: determine
    Sep 15 10:50:40 zimbra su(pam_unix)[6829]: session opened for user zimbra by mailadmin(uid=0)
    Sep 15 10:50:46 zimbra zimbramon[6846]: 6846:info: Starting services
    Sep 15 10:52:05 zimbra zimbramon[6885]: 6885:info: 2006-09-15 10:52:01, STATUS: : Cannot: determine
    Sep 15 10:52:20 zimbra zimbramon[6917]: 6917:info: Starting services
    Sep 15 10:52:27 zimbra su(pam_unix)[6829]: session closed for user zimbra

    -----------------------------------------------------------------------


    -------------- Output from sh -x ldap start ----------------------------

    ++ zimbra_store_directory=/opt/zimbra/store
    ++ export zimbra_store_sweeper_max_age=480
    ++ zimbra_store_sweeper_max_age=480
    ++ export zimbra_throttle_op_concurrency=1000,1000,1000,1000 ,1000
    ++ zimbra_throttle_op_concurrency=1000,1000,1000,1000 ,1000
    ++ export zimbra_tmp_directory=/tmp/zimbra
    ++ zimbra_tmp_directory=/tmp/zimbra
    ++ export zimbra_uid=501
    ++ zimbra_uid=501
    ++ export zimbra_user=zimbra
    ++ zimbra_user=zimbra
    ++ export zimbra_zmprov_default_soap_server=localhost
    ++ zimbra_zmprov_default_soap_server=localhost
    ++ export zimbra_zmprov_default_to_ldap=false
    ++ zimbra_zmprov_default_to_ldap=false
    ++ export zimlet_directory=/opt/zimbra/tomcat/webapps/service/zimlet
    ++ zimlet_directory=/opt/zimbra/tomcat/webapps/service/zimlet
    + export zmsetvars=true
    + zmsetvars=true
    + '[' xtrue = xfalse ']'
    + case "$1" in
    + start
    + checkrunning
    + getpid
    + '[' -f /opt/zimbra/openldap/var/run/slapd.pid ']'
    + '[' x = x ']'
    + RUNNING=0
    + '[' 0 = 0 ']'
    + '[' '!' -f /opt/zimbra/openldap-data/DB_CONFIG ']'
    ++ echo ldap://zimbra.bordengrammar.kent.sch.uk:389
    ++ awk '{print $1}'
    + my_url=ldap://zimbra.bordengrammar.kent.sch.uk:389
    + /opt/zimbra/libexec/zmconfigure /opt/zimbra/conf/slapd.conf.in /opt/zimbra/conf/slapd.conf
    + sudo /opt/zimbra/openldap-2.3.21/libexec/slapd -l LOCAL0 -4 -u zimbra -h ldap://zimbra.bordengrammar.kent.sch.uk:389 -f /opt/zimbra/conf/slapd.conf
    + sleep 2
    + getpid
    + '[' -f /opt/zimbra/openldap/var/run/slapd.pid ']'
    + '[' x = x ']'
    + echo 'ERROR - failed to start slapd'
    ERROR - failed to start slapd
    + echo ''

    + exit 1
    [zimbra@zimbra bin]$

    ------------------------------------------------------------------------

    ------ Output of ps auxww | grep zimbra | grep slapd -------

    zimbra 7106 0.0 0.0 3952 644 pts/3 S+ 10:58 0:00 grep slapd
    [zimbra@zimbra bin]$

    ------------------------------------------------------------------------


    ----------- Output of nslookup zimbra ---------------------------

    [root@zimbra bin]# host zimbra
    zimbra.bordengrammar.kent.sch.uk has address 192.168.0.10
    [root@zimbra bin]# nslookup zimbra
    Server: 192.168.0.2
    Address: 192.168.0.2#53

    Name: zimbra.bordengrammar.kent.sch.uk
    Address: 192.168.0.10

    ----------------------------------------------------------------

    ------------------ Output of nslookup 192.168.0.10 -----------------------

    [root@zimbra bin]# nslookup 192.168.0.10
    Server: 192.168.0.2
    Address: 192.168.0.2#53

    10.0.168.192.in-addr.arpa name = zimbra.bordengrammar.kent.sch.uk.

    --------------------------------------------------------------------------

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Do you have A & MX records pointing to your zimbra server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2006
    Posts
    7
    Rep Power
    9

    Default MX Records

    Hiya,

    Yep, I have the following output from an nslookup of mail.:

    jpb@jpb-desktop:~$ nslookup mail
    Server: 192.168.0.2
    Address: 192.168.0.2#53

    mail.bordengrammar.kent.sch.uk canonical name = zimbra.bordengrammar.kent.sch.uk.
    Name: zimbra.bordengrammar.kent.sch.uk
    Address: 192.168.0.10

    Cheers,

    Jools

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    That doesn't show me any MX record, what does dig show?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2006
    Posts
    7
    Rep Power
    9

    Default Dig output

    Hiya,

    dig mx gives the output below:


    jpb@jpb-desktop:~$ dig mx bordengrammar.kent.sch.uk

    ; <<>> DiG 9.3.2 <<>> mx bordengrammar.kent.sch.uk
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53004
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;bordengrammar.kent.sch.uk. IN MX

    ;; ANSWER SECTION:
    bordengrammar.kent.sch.uk. 86400 IN MX 10 mail.bordengrammar.kent.sch.uk.

    ;; AUTHORITY SECTION:
    bordengrammar.kent.sch.uk. 86400 IN NS smb1.bordengrammar.kent.sch.uk.

    ;; ADDITIONAL SECTION:
    smb1.bordengrammar.kent.sch.uk. 86400 IN A 192.168.0.2

    ;; Query time: 2 msec
    ;; SERVER: 192.168.0.2#53(192.168.0.2)
    ;; WHEN: Fri Sep 15 15:48:59 2006
    ;; MSG SIZE rcvd: 99


    Cheers,

    Jools

  6. #6
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    what about the installation logs /tmp/install.log* and /tmp/zmsetup.log*

  7. #7
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    ldap is trying to bind to the ldap_url value (from zmlocalconfig) which probably no longer resolves to an IP on your local box, right?
    Bugzilla - Wiki - Downloads - Before posting... Search!

Similar Threads

  1. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 12:34 PM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •