Results 1 to 5 of 5

Thread: Zimbra - excessive memory requirements for java/mysql

  1. #1
    Join Date
    Nov 2007
    Rep Power

    Default Zimbra - excessive memory requirements for java/mysql

    Hi guys,

    Need your help here, please.

    I have attached screenshot about what is going on on my system.

    I currently run:

    Release 7.0.0_BETA2_2897.UBUNTU10_64 UBUNTU10_64 FOSS edition.

    The system has got 80GB fast HDD and 4GB RAM. Zimbra uses pretty much all the memory and I struggle to tweak it. On a different system I was able to take it down to about 1.3GB memory usage.

    I have tried the following:

    # zmlocalconfig -e mailboxd_java_options=-server -Djava.awt.headless=true -XX:+UseConcMarkSweepGC -XX:NewRatio=2 -XX:PermSize=128m \
    -XX:MaxPermSize=128m -XX:SoftRefLRUPolicyMSPerMB=1 -Xms128m -Xmx128m
    # zmlocalconfig -e tomcat_java_heap_memory_percent=5
    # zmlocalconfig -e zmmtaconfig_interval=3600
    # zmlocalconfig -e zmstat_interval=300
    # zmlocalconfig -e mailboxd_java_heap_memory_percent=5
    # zmlocalconfig -e mailboxd_java_heap_new_size_percent=5
    # zmlocalconfig -e ldap_common_threads=16
    # zmlocalconfig -e ldap_common_toolthreads=8
    # zmlocalconfig -e ldap_db_cachesize=50000
    # zmlocalconfig -e ldap_db_idlcachesize=50000
    # zmlocalconfig -e ldap_db_dncachesize=0
    # zmlocalconfig -e zimbra_zmjava_options=-Xms128m -Xmx128m
    # zmprov mcf zimbraMessageCacheSize 5000

    but nothing is helping.

    Any ideas guys?

    Many thanks.

    Attached Images Attached Images

  2. #2
    Join Date
    May 2006
    Rep Power


    Zimbra uses lots of memory, 4GB may just not be enough. You dont say how many accounts are active on this server, but that'll have an affect on memory usage.

    It's also worth mentioning that as you are using a beta verison it's quite likely that it's memory usage has not been optimised yet.

  3. #3
    Join Date
    Nov 2007
    Rep Power



    Many thanks for your prompt reply.

    To confirm, I have 4 active users on the server, 8 accounts in total.

    4GB should be more than enough. I never had problem with Zimbra and with few tweaks it is able to run smoothly with even 2GB.

    Zimbra 7 beta 1 used in average 1.3GB RAM. I don't believe there is something fundamentally wrong with beta2, it is maybe I have done something wrong (see my first post about what I have done).

    I am looking for an advice how to minimize the number of running mysql and java/jetty processes as they take huge amount of ram than usual.

    Any advice please?

    Many thanks.

  4. #4
    Join Date
    Sep 2010
    Rep Power


    I was having weird issues with zimbra chewing up the ram and pushing the machine into swap. For an experiment i left it at the default of 60 and within a day was using 50% of my swap and system performance tanked. What i found that contained the beast is you tune vm.swapiness to zero. NOw the system is nice and responsive. I always do this on all 2.6 based boxes i have as the kernel is waaaaay to agressive in swapping things out. you can set it forwhatever you want but i would go for zero.

    To change the swappiness value A temporary change (lost on reboot) with a swappiness value of 10 can be made with

    sudo sysctl vm.swappiness=10
    To make a change permanent, edit the configuration file with your favorite editor:

    gksudo gedit /etc/sysctl.conf
    Search for vm.swappiness and change its value as desired. If vm.swappiness does not exist, add it to the end of the file like so:


  5. #5
    Join Date
    Sep 2010
    Rep Power


    I have zimbra at the memory defaults the only tuning i have done is swappiness to zero. Zimbra's actually pretty good at memory management it's the Linux kernel that tried to "free' more ram by swapping. If you throw up the swap wall the kernel doesn't have the ability to fake ram and therefore Zimbra will stay within the physical memory confines given it. 8 users on 4 gigs should be a breeze(it is now for me on 2 gigs and 8 users)..

Similar Threads

  1. Major Issue - 5.0RC2 NE to 5.0GA NE failed
    By DougWare in forum Installation
    Replies: 7
    Last Post: 01-06-2008, 08:56 PM
  2. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  3. Replies: 8
    Last Post: 02-27-2007, 03:10 AM
  4. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 11:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts