Results 1 to 3 of 3

Thread: zmlogger, syslog, rsyslog and stats

  1. #1
    Join Date
    Nov 2006
    Posts
    12
    Rep Power
    8

    Default zmlogger, syslog, rsyslog and stats

    Hi,

    Perhaps this was discussed before and I couldn't find the thread in the forum. After migrating/upgraded from 32bit OE 5.0.16 (yes if it's not broke..) -> 64bit 6.0.9 on a different server, I notice the logging stats were not working. Zimbra was collecting them in /var/log/zimbra-stats.log but for some strange reason the stats were not updating in the Admin Console.

    After poking around, I notice logger database was not updating and zmlogger (via zmlogswatch.out) was producing a lot of uninitialized value at line 564

    Use of uninitialized value in string eq at /opt/zimbra/libexec/zmlogger line 564, <> line 1551.
    Use of uninitialized value in string eq at /opt/zimbra/libexec/zmlogger line 564, <> line 1551.

    Looking at the code, zmlogger is trying to match fields from zimbra-stats.log. What I found interesting was on my setup rsyslogd logged a slightly different way that what zmlogger is expecting. Hence the errors.

    So instead of changing rsyslogd's format, I decided to see if zmlogger is expecting a syslog standard format.

    I setup syslog on the server (fairly quick process). Executed the zmsetupsyslog script and restarted zimbra. As I expected, the errors went away, updates started happening in zmlogger's database (logger/db/data) and Admin console shows the correct status.

    I hope this helps others who are in a similar situation as I was.

    -Charles
    zimbra 6.0.9, CentOS 5.5 x6.4

  2. #2
    Join Date
    Jun 2010
    Posts
    198
    Rep Power
    5

    Default

    Quote Originally Posted by loopietky View Post
    I setup syslog on the server (fairly quick process). Executed the zmsetupsyslog script and restarted zimbra. As I expected, the errors went away, updates started happening in zmlogger's database (logger/db/data) and Admin console shows the correct status.
    -Charles
    zimbra 6.0.9, CentOS 5.5 x6.4
    Hi Charles,

    Its a good one... but you don't need to restart the zimbra, you have restart only the zmstatctl service to make it work again.

  3. #3
    Join Date
    Mar 2009
    Location
    Sarajevo
    Posts
    44
    Rep Power
    6

    Default

    Hello. This seems similar to our problem, and I'd like to ask you for some help.
    We're using ZCS latest version 7.2.0 on Centos 5 and it worked fine. In order to setup central logging, a colleague installed rsyslog on Centos server. Now, Zimbra stats nor server status are not working.
    What's a solution? To change something or to install syslogd back? But, Zimbra surely works with rsyslog. How does it detect it? Should reinstallation with the same version help?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •