Results 1 to 8 of 8

Thread: HELP! Zimbra account not deleting mail off of server

  1. #1
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default HELP! Zimbra account not deleting mail off of server

    Hi

    I have a user account which has an external POP account. The account is setup to delete mail off the server, but it isn't. I continually downloads messages over and over again (he has more than 45,000 messages since he was polling every 60 seconds.

    We had this happen on Friday, but it was only a few emails coming in over and over. Our ISP (who hosts this POP account) said the mail server was logging in twice within four seconds (back to back) but getting an error and not deleting the mail. At that point, I had the ISP delete the mail manually, and it seemed to be working fine at that point.

    Now however, there appears to be something really wrong. Any ideas? There don't appear to be any errors in mailbox.log.

  2. #2
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Update: user is actually getting an error:
    Error: system failure: Unable to add incoming message, /opt/zimbra/store/incoming/1290956025429-11.msg does not exist.

    The failed accounts will not update until the problem(s) have been resolved.

  3. #3
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    Update: when 'manually' downloading email (while logged in as this user, using the 'Get Mail' button) I get two errors back to back. The second overwrites the first, but I was able to screen grab the first. See attachment. (The second error is the one listed earlier).
    Attached Images Attached Images

  4. #4
    Join Date
    Sep 2009
    Location
    Canberra, Australia
    Posts
    25
    Rep Power
    6

    Default

    We have a user experiencing the same problem.

    Any known fix for this?

    We should probably lodge it as a bug in bugzilla.

  5. #5
    Join Date
    Dec 2007
    Posts
    84
    Rep Power
    7

    Default

    When I have seen this, it's actually just a connection/client problem. Here is a brief explaination of HOW it can happen;

    Scenario that can set up the "problem"
    User joe@foobar.com has 40 (or 400) messaes in their inbox, most messages are text email, very small, with no attachments, but message number 39 (or 389) is some cute little [worthless] email with 4 or 40 mb attached file.

    What happens to "JOE"
    Joe connects from someplace with a limited or slow internet connection, and starts downloading his emails. He happily watches the status zoom by - 1,2,3,4,23,25, all zoom by really fast. Suddenly at 39 (or at 389) the download seems to "HANG" - note it is really not hanging, but is now downloading a huge file, but he doesn't know it, he's just upset that his download "STOPPED".

    What Joe does to TRIGGER THE PROBLEM;
    In frustration, after 7 minutes of "nothing happening", he shuts down his pop client, and tries again. It quickly downloads the first 38 (or 388) messages, and hangs again...

    If you happen to have an impatient user (or a stupid one), they can repeat this process 20 times over a few days, and their pop client now has 38 x 19 or 388x19 duplicate messages in their pop client.

    This can also happen if there are many emails and an unstable internet connection.

    Note: this is not a zimbra problem, but a handshaking problem between your pop server and your pop client. When the client requests "all new mail" the pop server starts to comply, when the connection fails, the pop client may not have confirmed receipt and marked the downloaded messages as having been received, so the pop server still thinks they are new....

    To get over this issue, have your user log on through the web portal and delete emails with attached files (download them from there whatever) and you may find that your problem has "GONE AWAY"...

    (we had a user who used to send "everyone" a 6mb ppt file every once in a while...(!))

  6. #6
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    mickier, I appreciate the reply, but that is not the case. These mailboxes auto. download email, so there is no user interaction. Also, we worked w/ the ISP that hosts the domain and POP accounts, and reviewed the mail.

  7. #7
    Join Date
    Nov 2009
    Posts
    4
    Rep Power
    5

    Default HELP! Zimbra account not deleting mail off of server

    Hi,

    I had the same problem today....

    I notice that an email on the ISP, that cannot be delete for whaterver raison, prevent other email to be delete as well.. So zimbra try to redownload and deleted again,...

    I fix that problem by login in the IPS webmail and delete manually the concerning email..... the email problem is usually the older email in the ISP box...

    I hope it help you!

  8. #8
    Join Date
    Apr 2008
    Location
    Brighton, ON, Canada
    Posts
    89
    Rep Power
    7

    Default

    I am now very sure that it is the filters. Whenever a filter fails it stops the download process. Since the emails aren't deleted off the server, it starts all over again the next time the system pops the mail. Disabling the filter(s) in question fixes this problem.

Similar Threads

  1. server dropped connection
    By ferra in forum Installation
    Replies: 20
    Last Post: 10-06-2008, 04:32 PM
  2. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 09:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •