Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 2nd Domain

  1. #1
    Join Date
    Dec 2010
    Posts
    8
    Rep Power
    4

    Default 2nd Domain

    Hi everybody,

    I'm testing Zimbra for use in our company.

    My problem is, when I create a account for a 2nd domain, I will become the error message:
    JavascriptError in method ZAAccount.setDomainChanged

    The primary domain works fine.

    I have created a 2nd domain (not an aliasdomain) and created a new cos for this domain.

    When I click on new account the wizzard is opening. I can see the cos for the standard domain (under account-type). When i change the domain name (under accountname), i will become the error message.

    Server is RedHat5, with the newest zimbra version. (60 Day-Trail Collaboration Server)
    I was loggedin with the globaladmin account.

    What must I do to create new accounts for the 2nd domain?

    Best regard

    Heiko

    PS
    I have make a screen from the error message
    Attached Images Attached Images
    Last edited by dolphinits; 12-03-2010 at 07:44 AM. Reason: Attach File

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    It works for me, how many accounts have you created in the primary domain? What errors do you see in the log files?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2010
    Posts
    8
    Rep Power
    4

    Default

    on the primary domain I have 10 normal accounts and 3 admin accounts.

    in mailbox.log I can see only info messages when I change the domain. (soap-CountAccountRequest)

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Are you behind a NAT router or firewall? If you are, do you have a Split DNS set-up (you need one)? Have you disabled the firewall and SElinux?
    Last edited by phoenix; 12-09-2010 at 01:55 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Dec 2010
    Posts
    8
    Rep Power
    4

    Default

    I have installed only iptables on the same server.

    But I will become the same error, after stopping the service.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by dolphinits View Post
    I have installed only iptables on the same server.

    But I will become the same error, after stopping the service.
    That wasn't the question, do you have a Split DNS set-up on your LAN?

    Adding multiple domains and creating accounts is a basic function of Zimbra Administration, if it didn't work I think we'd have heard about it before now.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Dec 2010
    Posts
    8
    Rep Power
    4

    Default

    Hm..

    The Server has two networkcards. One to connect to our internal LAN (Administration, Monitoring and Storagelinks) and one external connect (with his external IP, without nat).

    In our DNS we have one A-Record (Servername to IP) and one MX-Record (MX to CName) for the first domain (default domain.)

    The second domain hasn't no MX-Record at my first try. But hafter create the MX-Record for this 2nd domain I will see the same error.

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by dolphinits View Post
    In our DNS we have one A-Record (Servername to IP) and one MX-Record (MX to CName) for the first domain (default domain.)
    Where is this DNS server located, on the LAN or is it an external DNS server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Dec 2010
    Posts
    8
    Rep Power
    4

    Default

    that is an external DNS-Server (InternetX)

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by dolphinits View Post
    that is an external DNS-Server (InternetX)
    With the firewall active you will need a LAN DNS server so the IP address can be resolved correctly. Activate your firewall and run the commands from the 'Verify...' section of the Split DNS article to see if DNS resolution is working correctly (do it for the primary domain on your server not the new second domain).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 03:49 AM
  2. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  3. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 09:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •