Results 1 to 4 of 4

Thread: [SOLVED] Database corruption after rsync

  1. #1
    Join Date
    Jul 2010
    Posts
    3
    Rep Power
    5

    Default [SOLVED] Database corruption after rsync

    hi to all
    I need some help to make a safe copy of zimbra NE server.
    My problem is this:
    I make a new server identical to old server (Operatin System and version of ZCS) use the appropriate procedure (install whit -s option && remove the /opt/zimbra).
    I copy all data from old server (zmcontrol stop && rsync of /opt/zimbra) to external HDD mounted on.
    I copy all data from external HDD to new server on same position.
    I rerun the installation script whitout -s option but...
    ... when the script verify the store database all file are corrupt.
    But the original database are ok.
    therfore when the new system go up all services are ok but zmmailbx are down whit database error.
    ...

    thanks so much for all
    matteo

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    This is not thesame problem as the thread you've originally posted to, I'll move this into a new thread.

    What, exactly, are you trying to do? Have you looked in the wiki (or searched the forums) for details on how to move a server to another server? There are plenty of articles that cover what you're trying to do. When you get a problem or have a question, you should post exact details of the steps you've taken to arrive at the problem and any errors you find in the log files.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2010
    Posts
    3
    Rep Power
    5

    Default

    i'm sorry is my first post .. and my english is soo poor..
    The I try to move the server (to simulate to restore all data to new server) whit this procedure: Moving ZCS to Another Server » Zimbra :: Blog.
    I read many wiki in this forum and the exact step are:

    1) copy all data from old server to external lan disk (for external disk I use one ubuntu server whit nfs sharing) whit the command rsync -avH /opt/zimbra /backup
    2) create a new identical server (ubuntu 8.04 - 64bit) and install exactly version of ZCS whit the command ./install.sh -s
    4) remove the installation whit rm -r /opt/zimbra
    5) copy all data from backup to /opt/zimbra on new server (rsync -avH /backup /opt/zimbra)
    6) run zmfixperms to fix permission on file
    7) rerun install script whitout the -s option
    .. when the scrit ask if I want to check the message store database I reply yes and then found databse corrupt on all file.
    If I execute zmdbintegrityreport -v :

    Database errors found.
    /op/zimbra/mysql/bin [bla bla bla]
    Error: Incorrect information in file : ' ./mboxgroup1/appointment.frm'
    error: Corrupt
    mboxgroup1.data_source_item

    This for many many table (all I think)

    I try to reply the log but it's complicate because all sistem are vitual..

  4. #4
    Join Date
    Jul 2010
    Posts
    3
    Rep Power
    5

    Default

    I solved the problem,.. the question are simple,.. i'm a big stupid. I don't remember that the old server are 8Gb of RAM and the new server (virtual) are only 1Gb..
    On mysql_error log are :
    Error: cannot allocare xxxxxxxx byte of memory whit malloc! The total memory allocated xxxxx

    i'm sorry for this thread..
    thanks soo much for your reply
    best regards
    matteo

Similar Threads

  1. Replies: 23
    Last Post: 01-24-2013, 03:44 PM
  2. [SOLVED] rsync permision denied
    By get2guy in forum Administrators
    Replies: 4
    Last Post: 10-22-2010, 01:32 AM
  3. change ldap database
    By Grejao in forum Administrators
    Replies: 1
    Last Post: 12-07-2007, 08:39 AM
  4. Database corruption after restore
    By NightTwix in forum Administrators
    Replies: 1
    Last Post: 07-06-2007, 05:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •