I get the following error message when i try to send to a newly created zimbra account. I installed DKIM-Filter wherein i have set the inbound filter
in master.cf in

It was working fine before this, as i installed DKIM-Filter for verification of emails.

# Receive mail from the network and
# pass it to the content filter on localhost port 10025.
smtp inet n – n – – smtpd
-o smtpd_proxy_filter=
-o smtpd_client_connection_count_limit=10
# After-filter SMTP server. Receive mail from the content filter on
# localhost port 10026.
# inet n – n – – smtpd
-o smtpd_authorized_xforward_hosts=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o smtpd_data_restrictions=
-o mynetworks=
-o receive_override_options=no_unknown_recipient_chec ks

************************************************** ***

Delivery to the following recipient failed permanently:


Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 5.1.1 <testadmin@americanmutualloans.com>: Recipient address rejected: americanmutualloans.com (state 14).

----- Original message -----

MIME-Version: 1.0
Received: by with SMTP id m9mr5937508far.79.1291655562592; Mon,
06 Dec 2010 09:12:42 -0800 (PST)
Received: by with HTTP; Mon, 6 Dec 2010 09:12:42 -0800 (PST)
Date: Mon, 6 Dec 2010 11:12:42 -0600
Message-ID: <AANLkTikp-fs1kSSFuAr95=kPpQ_Jxv3gfEb0XojjWpVo@mail.gmail.com >
Subject: Test After DKIM stopped
From: Ash <ash@gmail.com>
To: testadmin@americanmutualloans.com
Content-Type: multipart/alternative; boundary=001636c5b3e1fb01290496c0fe38

Did anyone faced same error??