Results 1 to 7 of 7

Thread: [SOLVED] zimbraMtaSaslAuthEnable:

  1. #1
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default [SOLVED] zimbraMtaSaslAuthEnable:

    zmbra OS 6.0.9 on CentOS
    i had mta auth disabled for security reasons, but now i had to re-enable it;
    very frustrating, after enabled on admin web gui, still i am not able to send authenticated;
    i note that:
    zimbraMtaSaslAuthEnable: FALSE
    so i must enable it, can i do it by cmd line? without pains?
    zmlocalconfig -e zimbraMtaSaslAuthEnable=TRUE

    thnx

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    59

    Default

    If this is for a client connection the get them to use the correct Submission port which is 587 and is already set to require a secure connection.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    thnx bill for your hint, but there are so many client that use smtp auth that i am unable to change all of them

    what i note is that in all other server server 6.0.9 CentOS 5 i have:
    Code:
    grep smtpd_sasl_auth_enable main.cf
    smtpd_sasl_auth_enable = yes
    but in this one i have
    Code:
    grep smtpd_sasl_auth_enable main.cf
    smtpd_sasl_auth_enable = no
    according to u can i change into main.cf to get it permanent?
    the change with zmlocalconfig in my previuos post vanished after restart

  4. #4
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    it doesn't work
    it is overwritten after postfix reloading

    still
    Code:
    grep smtpd_sasl_auth_enable *
    main.cf:smtpd_sasl_auth_enable = no
    main.cf.default:smtpd_sasl_auth_enable = no
    master.cf:  -o smtpd_sasl_auth_enable=yes
    master.cf:      -o smtpd_sasl_auth_enable=no
    master.cf.in:  -o smtpd_sasl_auth_enable=yes
    master.cf.in:   -o smtpd_sasl_auth_enable=%%zimbraMtaSaslAuthEnable%%
    [ 17:41:00 zimbra@zimbra ~/postfix/conf ]$
    please help....
    Last edited by maumar; 12-10-2010 at 08:49 AM.

  5. #5
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    i tried 587 submission port but without sasl authentication enabled there is no use, i get:
    Code:
    Dec 10 18:29:49 zimbra postfix/smtpd[8971]: NOQUEUE: reject: RCPT from host102-70-dynamic.8-79-r.retail.telecomitalia.it[79.8.70.102]: 554 5.7.1 <host102-70-dynamic.8-79-r.retail.telecomitalia.it[79.8.70.102]>: Client host rejected: Access denied; from=<xxx at xxxx.it> to=<aaaa at kkkk.it> proto=ESMTP helo=<matanui.datalogica.com>
    as yiu can see, w/out sasl there no authentication even with 587 submission port.
    for your info, i tried the same client configuration with another server, and 587 submission port did work like a charm

    so, my issue is:
    how can i re-enable smtpd_sasl_auth_enable ?
    please advice...

  6. #6
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    Even reinstalling doesen't fix the issue ;(

  7. #7
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    10

    Default

    solved..at last, but...better later then never ghghgh

    zmprov ms zimbra.xxxxxx.it zimbraMtaSaslAuthEnable TRUE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •