Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: [SOLVED] Unable to change the logo website

  1. #1
    Join Date
    Jul 2006
    Location
    Pisa
    Posts
    135
    Rep Power
    9

    Default [SOLVED] Unable to change the logo website

    Hi

    Running zimbra 4
    I tried to change logo and website for my zimbra interface, in the base_subs.txt
    I changed the rows as follow

    LogoImgDir = /zimbra/skins/_base/logos
    LogoURL = http://www.mycompany.ext

    The logo works but the link still goes to www.zimbra.com.
    I noticed that in light_subs.txt there is logo and url defined too
    and I uncommented the rows, but no result.
    What can be wrong ?
    Thank you

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Is this the Network Edition or the Open Source Edition?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2006
    Location
    Pisa
    Posts
    135
    Rep Power
    9

    Default

    I'm using network editin in trial period

    can this cause the problem ?


    thank you

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    No, that shouldn't be a problem. Have you seen the documentation in the wiki here about themes? There's also some info about replacing logo files.

    I'm not a great coder so if you still have problems someone else may give you a few pointers or you could drop an email to zimbra support.
    Last edited by phoenix; 09-21-2006 at 08:14 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    bug 10588, we're working on fixing it.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #6
    Join Date
    Jul 2006
    Posts
    17
    Rep Power
    9

    Thumbs up price for changing logo only

    i'm curios to know, i just want features in opensource edition, but want to change the logo, i did not need support (smi compony - limited money , coz someday i'll make it company myself like freelance rather than working to org/gov ) but realy love to zimbra.

    in other word opensource edition plus change logo only, how to calculate the price?

  7. #7
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,322
    Rep Power
    13

    Default

    Quote Originally Posted by ir_syam
    In other word opensource edition plus change logo only, how to calculate the price?
    Not possible.

    If you _need_ to rebrand Zimbra, you _need_ to go Network Edition (ISP, Email, Std or Pro).

  8. #8
    Join Date
    Dec 2006
    Posts
    184
    Rep Power
    8

    Default

    Quote Originally Posted by marcmac View Post
    bug 10588, we're working on fixing it.
    This seems to be working... (got it via a support request)

    . cd /opt/zimbra/tomcat/webapps/zimbra/js
    . gzip -d -S .zgz ZimbraMail_all.js.zgz
    . Edit ZimbraMail_all.js
    . Search for the following setting: ZmSetting.INIT[ZmSetting.LOGO_URI]
    . Change this value to your URL
    . Save this File
    . gzip -S .zgz ZimbraMail_all.js

    Now, clicking on the top left logo, redirects correctly.

    But, clicking on the logo on the login page still points to zimbra...




    TIA...

  9. #9
    Join Date
    Jan 2007
    Posts
    49
    Rep Power
    8

    Default Change link at logo Zimbra.

    I can't find "ZmSetting.INIT[ZmSetting.LOGO_URI]" in my ZimbraMail_all.js (gzip from ZimbraMail.js.zgz). I'm using 4.5.0 Release. Please help me.

    In my ../zimbra/js folder, there is a ZimbraMail_all.js and a ZimbraMail_all.js.zgz. If i gzip ZimbraMail_all.js.zgz, it will overwrite ZimbraMail_all.js. has it problem ?

    Thanks.

  10. #10
    Join Date
    Dec 2006
    Posts
    184
    Rep Power
    8

    Default

    Quote Originally Posted by celeron View Post
    I can't find "ZmSetting.INIT[ZmSetting.LOGO_URI]" in my ZimbraMail_all.js (gzip from ZimbraMail.js.zgz). I'm using 4.5.0 Release. Please help me.

    In my ../zimbra/js folder, there is a ZimbraMail_all.js and a ZimbraMail_all.js.zgz. If i gzip ZimbraMail_all.js.zgz, it will overwrite ZimbraMail_all.js. has it problem ?

    Thanks.
    By default, when you gzip the .js file, it will remove it. I believe there's a switch to preserve it, but if not make a copy prior to gzipping it...

    Note that this was fixed on 4.5.2 (and 4.5.3) and with the DST changes coming on sunday, you might as well move straight to that...

    My .02...

Similar Threads

  1. AntiVirus unable to connect to localhost
    By net4home in forum Administrators
    Replies: 15
    Last Post: 07-25-2007, 05:55 PM
  2. Change Zimbra Logo Network Edition
    By joaohv in forum Developers
    Replies: 1
    Last Post: 06-22-2007, 12:52 PM
  3. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  4. Update overwrites logo change
    By kogo in forum Administrators
    Replies: 0
    Last Post: 12-28-2006, 06:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •