Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: permissions hosed on /opt/zimbra/index/0/11/index/0/segments

  1. #1
    Join Date
    Jan 2006
    Posts
    83
    Rep Power
    9

    Default permissions hosed on /opt/zimbra/index/0/11/index/0/segments

    so i upgraded from 3.5 to 4.01 under debian this week, now i'm seeing this stuff going on.
    I ran zmfixperms, and it still seems to keep happening! what can i do!?

    2006-09-21 00:01:20,083 INFO [LmtpServer-3] [name=user@mail.domain.com;] ZimbraLmtpBackend - try again for message user@mail.domain.com: exception occurred
    com.zimbra.cs.service.ServiceException: system failure: indexMessage caught IOException
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    at com.zimbra.cs.index.Indexer.indexMessage(Indexer.j ava:161)
    at com.zimbra.cs.mailbox.Message.reindex(Message.java :439)
    at com.zimbra.cs.mailbox.Mailbox.endTransaction(Mailb ox.java:4338)
    at com.zimbra.cs.mailbox.Mailbox.addMessageInternal(M ailbox.java:3297)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3040)
    at com.zimbra.cs.mailbox.Mailbox.addMessage(Mailbox.j ava:3024)
    at com.zimbra.cs.filter.ZimbraMailAdapter.addMessage( ZimbraMailAdapter.java:325)
    at com.zimbra.cs.filter.ZimbraMailAdapter.doDefaultFi ling(ZimbraMailAdapter.java:319)
    at com.zimbra.cs.filter.RuleManager.applyRules(RuleMa nager.java:182)
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver MessageToLocalMailboxes(ZimbraLmtpBackend.java:308 )
    at com.zimbra.cs.lmtpserver.ZimbraLmtpBackend.deliver (ZimbraLmtpBackend.java:122)
    at com.zimbra.cs.lmtpserver.LmtpHandler.doDATA(LmtpHa ndler.java:420)
    at com.zimbra.cs.lmtpserver.LmtpHandler.processComman d(LmtpHandler.java:197)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:231)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:198)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.io.IOException: Could not create index /opt/zimbra/index/0/24/index/0 (directory already exists)
    at com.zimbra.cs.index.MailboxIndex.openIndexWriter(M ailboxIndex.java:906)
    at com.zimbra.cs.index.MailboxIndex.addDocument(Mailb oxIndex.java:349)
    at com.zimbra.cs.index.Indexer.addDocument(Indexer.ja va:354)
    at com.zimbra.cs.index.Indexer.addDocument(Indexer.ja va:324)
    at com.zimbra.cs.index.Indexer.indexMessage(Indexer.j ava:156)
    ... 16 more
    Caused by: java.io.IOException: Lock obtain timed out: Lock@/opt/zimbra/apache-tomcat-5.5.1...3de-write.lock
    at org.apache.lucene.store.Lock.obtain(Lock.java:58)
    at org.apache.lucene.index.IndexWriter.<init>(IndexWr iter.java:223)
    at org.apache.lucene.index.IndexWriter.<init>(IndexWr iter.java:173)
    at com.zimbra.cs.index.MailboxIndex.openIndexWriter(M ailboxIndex.java:887)
    ... 20 more
    2006-09-21 00:01:20,084 INFO [LmtpServer-3] [] LmtpHandler - [192.168.1.9] 451 4.0.0 Temporary message delivery failure try again (DATA)
    2006-09-21 00:02:10,861 INFO [IndexWritersSweeper] [] MailboxIndex - open index writers sweep: before=1, closed=1, after=0 (0ms)

  2. #2
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    chown -R zimbra:zimbra /opt/zimbra/store /opt/zimbra/index

    Or, for a permanent fix, uninstall debian and use a distro with a decent kernel.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2006
    Posts
    83
    Rep Power
    9

    Default

    Quote Originally Posted by marcmac
    chown -R zimbra:zimbra /opt/zimbra/store /opt/zimbra/index

    Or, for a permanent fix, uninstall debian and use a distro with a decent kernel.
    hah

    so it is the redo log problem. I did actually just update my kernel to 2.6.16 2.6.16-18~bpo.1 ..
    i'll try 2.6.17 i guess!
    Last edited by jholder; 09-22-2006 at 09:18 PM.

  4. #4
    Join Date
    Jan 2006
    Posts
    83
    Rep Power
    9

    Default

    any idea if a vanilla kernel works well with zimbra under debian?

  5. #5
    Join Date
    May 2006
    Posts
    52
    Rep Power
    9

    Default kernel on debian

    i just had the same question.

    should i go back on something like 2.4.33.3 from 2.6.x?

    thanx christof

  6. #6
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Quote Originally Posted by tyco
    i just had the same question.

    should i go back on something like 2.4.33.3 from 2.6.x?

    thanx christof
    Debian baffles me. You need a newer kernel, not an older kernel. And 2.4 is dead in the water, so don't even try it.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    Join Date
    May 2006
    Posts
    52
    Rep Power
    9

    Default which kernel best suitalbe for debian 3.1 and zimbra 4.01

    still i would love to know if its possible to run zimbra on 2.4.x on debian 3.1.

    thanx christof

  8. #8
    Join Date
    May 2006
    Posts
    52
    Rep Power
    9

    Default 2.4 kernel on deian from source

    i tried today to build a custom kernel 2.4.x on debian. but could not get the zimbra running.

    since i am running the zimbra on a vmware guest system on a 2.6.x kernel i have a very high timeshift so i cannot sync via ntp.

    does anybody know a solution?

    thanx

  9. #9
    Join Date
    Jan 2006
    Posts
    83
    Rep Power
    9

    Default

    Quote Originally Posted by tyco
    i tried today to build a custom kernel 2.4.x on debian. but could not get the zimbra running.

    since i am running the zimbra on a vmware guest system on a 2.6.x kernel i have a very high timeshift so i cannot sync via ntp.

    does anybody know a solution?

    thanx
    linux-source-2.6.17-8~bpo.1 from backports is working great for me!

  10. #10
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    12

    Default

    recent 2.6 kernels from testing/unstable work for me. search the forums for the setuid bug, make sure it's a recent kernel.

Similar Threads

  1. backup and forgot to copy permissions
    By dhickey in forum Installation
    Replies: 8
    Last Post: 01-18-2007, 10:56 AM
  2. Replies: 0
    Last Post: 09-23-2006, 10:25 AM
  3. Directory permissions list?
    By kevindods in forum Installation
    Replies: 2
    Last Post: 06-19-2006, 12:56 AM
  4. MTA is Dying after yum update
    By tonyawbrey in forum Administrators
    Replies: 27
    Last Post: 04-02-2006, 06:11 PM
  5. Replies: 2
    Last Post: 03-10-2006, 02:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •