Results 1 to 9 of 9

Thread: Deleting account from cli does not delete mailbox?

Hybrid View

  1. #1
    Join Date
    Sep 2010
    Posts
    54
    Rep Power
    5

    Default Deleting account from cli does not delete mailbox?

    Hi folks,

    Today I deleted some accounts using zmprov da account@domain command.

    Account was removed, but it seems that the associated mailbox is still on disk, as i get error messages from mailboxpurge task:

    Code:
    2011-01-06 15:33:49,398 WARN  [MailboxPurge] [mid=7;] mailbox - no account found in directory for mailbox 7 (was expecting 313562d2-ae6d-4434-8cc5-24d62e49cdfc)
    2011-01-06 15:33:49,398 WARN  [MailboxPurge] [mid=7;] purge - Unable to purge mailbox 7
    com.zimbra.cs.account.AccountServiceException: no such account: 313562d2-ae6d-4434-8cc5-24d62e49cdfc
    ExceptionId:MailboxPurge:1294324429398:2abc3de9bcb87189
    Code:account.NO_SUCH_ACCOUNT
            at com.zimbra.cs.account.AccountServiceException.NO_SUCH_ACCOUNT(AccountServiceException.java:177)
            at com.zimbra.cs.mailbox.Mailbox.getAccount(Mailbox.java:522)
            at com.zimbra.cs.mailbox.PurgeThread.run(PurgeThread.java:147)
    Is there any CLI command to properly remove mailbox by its ID, or was there any parameter to use with zmprov da command to delete mailbox on the fly?

    Thanks for your answers.

  2. #2
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    same here
    Zibra NE 7.0.0
    Code:
    011-03-05 19:35:29,734 WARN  [ScheduledTask-1] [mid=7;] mailbox - no account found in directory for mailbox 7 (was expecting 15b931d2-2271-4cb4-8883-2ee2a65dce23)
    2011-03-05 19:35:29,734 WARN  [ScheduledTask-1] [mid=7;] datasource - Scheduled DataSource import failed.
    com.zimbra.cs.account.AccountServiceException: no such account: 15b931d2-2271-4cb4-8883-2ee2a65dce23
    ExceptionId:ScheduledTask-1:1299350129734:36a8385fb95d1500
    Code:account.NO_SUCH_ACCOUNT
            at com.zimbra.cs.account.AccountServiceException.NO_SUCH_ACCOUNT(AccountServiceException.java:178)
            at com.zimbra.cs.mailbox.Mailbox.getAccount(Mailbox.java:529)
            at com.zimbra.cs.mailbox.MailboxManager.getMailboxById(MailboxManager.java:474)
            at com.zimbra.cs.mailbox.MailboxManager.getMailboxById(MailboxManager.java:390)
            at com.zimbra.cs.datasource.DataSourceTask.call(DataSourceTask.java:66)
            at com.zimbra.cs.datasource.DataSourceTask.call(DataSourceTask.java:28)
            at com.zimbra.common.util.TaskScheduler$TaskRunner.call(TaskScheduler.java:67)
            at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
            at java.util.concurrent.FutureTask.run(FutureTask.java:138)
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:98)
            at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:206)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:662)

  3. #3
    Join Date
    Sep 2010
    Posts
    54
    Rep Power
    5

    Default

    Hi Maumar,
    Seems that a restart of mailboxd fixes the problem.
    Did you try ?

  4. #4
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    thnx for suggestion.....
    i just issue a
    Code:
    zmcontrol restart
    but it didn't solve anything, sadly

  5. #5
    Join Date
    Feb 2010
    Posts
    1
    Rep Power
    5

    Default

    I have the same problem...

  6. #6
    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    3

    Default

    Same problem in our environment with 7.1.1. Here is what I've discovered so far...

    Our IDM solution is running the zmprov da on our main LDAP server which results in account removal but not removal of the mail. Tests running zmprov da on our mailbox servers instead of the LDAP server seem to remove both the account and the mail. The tests also reveal the zmprov da does not need to be run on the same mailbox server as the mailbox you are trying to removal. It only needs to be run on a mailbox server. Based on these findings we are going to adjust our IDM to run the zmprov da on one of our mailbox servers.

    I'm still researching how to clean up the orphaned mailboxes.

    Cheers
    Chad

  7. #7
    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    3

    Default

    Zimbra support provided a perl script called zmfindorphans.

    In a nutshell... The script compares the zimbraIds from LDAP with those in MySQL. The Ids that exist in the database but not LDAP are orphaned so the script removes Id from the database and directory containing the mail.

    Chad

  8. #8
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    I have some NE and some OS zimbra installations.
    Should I open a support ticket to have the script? or you can share freely it with us?

  9. #9
    Join Date
    Dec 2011
    Posts
    4
    Rep Power
    3

    Default Orphan Cleanup Script

    I pinged support and they said it was ok to share. Find attached.

    Cheers
    Chad
    Attached Files Attached Files

Similar Threads

  1. [SOLVED] Can't delete domains with wiki account
    By lindworm in forum Administrators
    Replies: 13
    Last Post: 04-08-2011, 03:40 PM
  2. HELP! Zimbra account not deleting mail off of server
    By strafford in forum Administrators
    Replies: 7
    Last Post: 01-04-2011, 10:08 AM
  3. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  4. [SOLVED] Web Service to create mailbox account
    By jv1410 in forum Developers
    Replies: 1
    Last Post: 10-19-2007, 05:31 PM
  5. Delete Account (zcs-3.0.0_M3_436a.FC3)
    By chanck in forum Installation
    Replies: 2
    Last Post: 01-17-2006, 06:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •