Results 1 to 10 of 10

Thread: Wrong message header

  1. #1
    Join Date
    Jan 2011
    Location
    Poland
    Posts
    27
    Rep Power
    4

    Default Wrong message header

    Hi,

    This is my first post here, so welcome everyone! I have developed Zimbra ZCS Opensource Edition in my company and I'm very pleased with Zimbra. Recently users reported me very strange and very important issue (bug?).
    We're using Zimbra ZCS Opensource Edition with Outlook 2007 (no Outlook connector). Users have configured IMAP access to their mailboxes in Outlook. From time to time they recieve message with wrong header.
    Example:
    Message orginally is sent by user A to user B. User B recieves this message as it was sent by user C (sender, subject, date is wrong, content of message is correct). Next message listed (sorted by date) in mailbox is recieved from user C (with same sender, subject, date and content) - this message is correct.

    And best part: On Zimbra Webmail everything is OK. Only message in Outlook is downloaded with wrong header.

    Anyone had same problems? Looking forward for any suggestions.

    Regards,

    Adam H.

  2. #2
    Join Date
    Jan 2011
    Location
    Poland
    Posts
    27
    Rep Power
    4

    Default

    Any suggestions in this matter are welcome and highly appreciated...
    If it's a security bug, than it's very important and need to be quickly reported.

  3. #3
    Join Date
    Jul 2009
    Location
    San Jose, CA
    Posts
    4
    Rep Power
    6

    Default Re: Wrong message header

    I have a similiar problem with Zimbra Web Client.
    Outlook 2007, imap, no connector
    Release 6.0.9_GA_2686.RHEL5_64_20101115224141 RHEL5_64 NETWORK edition

    Message header show bogus sender with correct sender.
    Zimbra log show correct sender
    Sync log show additional incorrect info with something that look like a wildcard match. Look like wildcard match pickup something from several days earlier.

    A reply to all work as expected with only email to the real sender.

    Not sure if this help!

  4. #4
    Join Date
    Jan 2011
    Location
    Poland
    Posts
    27
    Rep Power
    4

    Default

    Don't you think it's a huge problem? Users receive messages from persons who really didn't sent them emails. How can I explain this situation to my CEO? Can I report this as a bug / error ? Any chances for higher priority with this?

    Regards.

  5. #5
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    You can try searching Bugzilla for your issue and if you can't find it submitting a bug. Beyond that my guess would be it's a bug in Office 2007 as I have never seen this issue in any of my IMAP clients.

  6. #6
    Join Date
    Feb 2008
    Location
    Urbana-Champaign, IL
    Posts
    68
    Rep Power
    7

    Default Same problem

    We're also having the same problem here.

    One person received five emails in a row, all from different senders, with the wrong name displayed in the To: header. The person in the To: header is not mentioned anywhere in any of the messages.

    This is via the Web client -- select 'Show Original' does show the correct header, as do the logs.

    Bug reported created: Bug 56023 – Wrong name is displayed in To: header for recipients
    Last edited by lindsey; 01-25-2011 at 04:12 PM. Reason: Added link to bug report

  7. #7
    Join Date
    Mar 2011
    Posts
    2
    Rep Power
    4

    Default

    I found this thread after searching for a solution for the same problem.
    We use a mailbox on a courier IMAP-server to store project relates e-Mails, at the moment about 30GB of mail data.
    We have the same problem with wrong headers, using Seamonkey Mail or Thunderbird shows the correct header.
    It seems that this is a serious bug in Outlook, because with other clients it does not occur.
    I guess Microsoft wants to sell Exchange-servers and not having people using open source solutions.

    The only solution we have found is to download not only headers but the whole messaghe in send/receive settings. As PST size is limited to 20GB by default, the registry key for PST size must be changed:

    [HKEY_CURRENT_USER\Software\Microsoft\office\12.0\o utlook\PST]
    "MaxLargeFileSize"=dword:00009000
    "WarnLargeFileSize"=dword:00008c00
    [HKEY_CURRENT_USER\Software\Policies\Microsoft\offi ce\12.0\outlook\PST]
    "MaxLargeFileSize"=dword:00009000
    "WarnLargeFileSize"=dword:00008c00

    We have also no better solution at the moment, has anybody yet found a better workaround?

  8. #8
    Join Date
    Jan 2011
    Location
    Poland
    Posts
    27
    Rep Power
    4

    Default

    Hi,
    It is good to hear that I'm not alone in this bug.
    Setting to download whole message solves the problem? What if I have set it by default and issue still persists? What I've noticed is that from time to time not all messages are synced from Sent folder. Users sends message, I can see it on SOAP, but can't see it in Sent folder in Outlook (I have checked Sent folder settings in Outlook). Anyone noticed same issues?

    Regards,

    Adam

  9. #9
    Join Date
    Mar 2011
    Posts
    2
    Rep Power
    4

    Default

    Yes, you're not alone :-) And also we haven't drunken too much.
    Anyway, a little about our configuration:
    We have a central Exchange-Server on another site which we connect to through a 8Mbit connection, cache mode enabled on all clients.
    For storing project related mails I have one server running on Debian Squeeze with a courier IMAP. For this purpose I have a mailbox that is used by about 15 people to drag project mails to.
    And we had exactly the same problem as you had, mostly if someone has forwarded a message the sender appearing is the original sender and not the forwarder.
    So we went to the send/tranmit setting and changed it to download the entire message and not only headers. Headers are shown correctly then, but the disadvantage is that the space is occupied on all clients and synchronization always takes some time. Also as I already wrote we had to get rid of the size limitation in the PST.
    I do not like this solution as the server is in house, really fast and there's no need for caching the data locally.
    I would suggest that you just try it in the same way until hopefully one day this bug will be fixed.

  10. #10
    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    3

    Smile Fixed - It was indeed a local contact created.

    I also had this problem and I fixed it. You guys lead me to it thank you.

    My problem was a iMac user with outlook 2011. This person created a local contact for himself and added 3 other people's email addresses to it as additional email addresses. I'm guessing they intended on it being a distribution group but fubar'd that up royally.

    So i went into his local contacts, did a search for the suspect email addresses and sure enough the search results returned his contact along with the others that the header was referring to incorrectly.

    i then opened his contact he created and deleted the additional email addresses attached to that contact. Problem solved.

    figuring this one out was like playing detective work. i registered here just to leave feedback because i could not find much help online about this very strange problem.

    Scaggs

Similar Threads

  1. [SOLVED] Lot of mails deferred
    By pigui in forum Administrators
    Replies: 17
    Last Post: 04-10-2012, 06:15 AM
  2. Emails bouncing with "Error Text: 401,'null'"
    By sholden in forum Zimbra Connector for Outlook
    Replies: 27
    Last Post: 08-20-2008, 05:59 PM
  3. Message Sent to Wrong Recipient
    By jpcaldwell in forum Administrators
    Replies: 2
    Last Post: 03-23-2007, 01:14 AM
  4. Replies: 29
    Last Post: 02-18-2007, 07:45 PM
  5. Inbox unread message count is wrong
    By dhallweb in forum Administrators
    Replies: 6
    Last Post: 08-26-2006, 02:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •