Results 1 to 4 of 4

Thread: Squid ldap auth problem..

  1. #1
    Join Date
    Jan 2011
    Rep Power

    Default Squid ldap auth problem..

    Hi All,

    I have some problems using Zimbra's LDAP to squid authentication.

    I checked the how to from this site Configure squid for LDAP authentication using squid_ldap_auth helper and try to test using squid_ldap_auth helper and my server information:

    /usr/lib/squid/squid_ldap_auth -v 3 -b "dc=zimbra,dc=grupotusa,dc=com" -f "(&(uid=%s)(objectClass=*))" -h
    testuser testpwd
    squid_ldap_auth: WARNING, LDAP search error 'No such object'
    ERR Success

    it seems that the object was no found in the directory, then I change the command and as:

    /usr/lib/squid/squid_ldap_auth -v 3 -b "dc=grupotusa,dc=mx" -f "(&(uid=%s)(objectClass=*))" -h
    testuser testpwd
    ERR Success

    Now I don't get the search error, but I can't validate the user.

    I'm running Zimbra on Centos, that's the version:

    Release 6.0.5_GA_2213.RHEL5_20100202220948 CentOS5 FOSS edition.

    Anyone can share me any tip?

    Note: The domain,user and passwords are valid on the server and I can login to read email.

  2. #2
    Join Date
    Jan 2011
    Rep Power

    Default Fixed

    I was researching about this issue and found the next:

    Anonymous Searches
    For new installations of ZCS 6.0, anonymous searches of the directory are
    disabled. (Bug 15378) When you upgrade to 6.0, anonymous searches of the
    directory are enabled, matching previous release behavior.
    To disable anonymous search after upgrading, on each LDAP server, as
    zimbra run /opt/zimbra/libexec/zmldapanon -d
    To enable anonymous access at any point after it is disabled, on each LDAP
    server run /opt/zimbra/libexec/zmldapanon -e
    Important: Enabling anonymous binds is not recommended as it may expose
    data not intended for anonymous access

    I activated the anonymous searches and it works.


  3. #3
    Join Date
    Jun 2011
    Rep Power


    Searching about this issue for a few days. This solution worked for me! Thank you.

  4. #4
    Join Date
    Jan 2012
    Rep Power


    This worked for me:

    /usr/lib/squid/ldap_auth -v 3 -b "ou=people,dc=something,dc=com" -f "(&(uid=%s)(objectClass=zimbraAccount))" -h MyLDAPHost -D "uid=zimbra,cn=admins,cn=zimbra" -w PASSWORD

Similar Threads

  1. Replies: 2
    Last Post: 01-17-2008, 08:45 PM
  2. About external LDAP problem, urgent!
    By bylong in forum Administrators
    Replies: 5
    Last Post: 08-24-2007, 07:10 PM
  3. Zimbra + Samba LDAP auth problems
    By fajarpri in forum Installation
    Replies: 3
    Last Post: 07-04-2007, 11:39 PM
  4. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 04:29 AM
  5. ldap pasword problem
    By jasonwillis in forum Installation
    Replies: 15
    Last Post: 03-15-2006, 07:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts