Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Mandatory Domain Signature assistance please

  1. #1
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default [SOLVED] Mandatory Domain Signature assistance please

    I'm a bit slow on the implementation here, but back in Nov '09 the zimbraDomainMandatoryMailSignatureEnabled options went live. The instructions are easy enough to follow.

    In order to create a system wide mandatory signature the following steps can be
    taken.
    zmprov mcf zimbraDomainMandatoryMailSignatureEnabled TRUE
    zmprov mcf zimbraDomainMandatoryMailSignatureText "some text"
    zmprov mcf zimbraDomainMandatoryMailSignatureHTML "<html><body>some html
    text</body></html>"

    Restart amavis to apply the configuration and write out the global signature
    files used by altermime.
    After a quick "zmprov gd domain.com" as the Zimbra user I got the following.

    Code:
    zimbraDomainMandatoryMailSignatureEnabled: TRUE
    zimbraDomainMandatoryMailSignatureHTML: <html><body>test disclaimer html</body></html>
    zimbraDomainMandatoryMailSignatureText: test disclaimer text
    I assumed this should indicate that the disclaimer text would be added to all further emails. The system wide signature shoud be tagged on below my normal user signature I would assume as well.

    It isn't. I get the user sig, but nothing else added. Any ideas as to what might be wrong? I have restarted amavisd, I have used zmcontrol restart to reload the whole of Zimbra, but I have not restarted the physical server.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  2. #2
    Join Date
    Mar 2011
    Posts
    19
    Rep Power
    4

    Default

    did you manage to get the disclaimer to attach itself to all emails?

  3. #3
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    I never did. I've had issues getting it to work and haven't looked at it recently. I'll be upgrading to 7.1 soon and will probably attempt to make it work after that.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  4. #4
    Join Date
    Sep 2010
    Posts
    26
    Rep Power
    5

    Default As the Zimbra user

    Quote Originally Posted by quietas View Post

    After a quick "zmprov gd domain.com" as the Zimbra user I got the following.
    I have setup zimbraDomainmandatoryMailSignature correctly... but when I try to restart Amavis to apply the configuration, it says it must be ran as a Zimbra user..
    How do I run this as a Zimbra user? I thought root would work...

  5. #5
    Join Date
    Mar 2011
    Posts
    19
    Rep Power
    4

    Default

    su - zimbra

    that should log you on as a zimbra user from root

  6. #6
    Join Date
    Mar 2011
    Posts
    19
    Rep Power
    4

    Default

    could you specify which Zimbra version you got the domain disclaimer working on? and the steps done to get it working?

    zmcontrol -v

    will display your zimbra cs version.

    thanks!

  7. #7
    Join Date
    Sep 2010
    Posts
    26
    Rep Power
    5

    Default

    Quote Originally Posted by gra View Post
    could you specify which Zimbra version you got the domain disclaimer working on? and the steps done to get it working?

    zmcontrol -v

    will display your zimbra cs version.

    thanks!
    http://www.zimbra.com/forums/adminis...tml#post216377 - Shows a screen shot of what I did.. I finally got it to accept when I removed the quotation marks.

    The Zimbra version should be: Client Version: 6.0.6_GA_2330.RHEL5_64 Client Release: 20100505193959 Build Date: 20100505-1951

    Again, I'm new to Zimbra but definitely put in my hours learning.. In regards to zmcontrol.. I see that in opt/zimbra/bin/, but the CLI Utility doesn't pull up in the terminal like zmprov did. My command knowledge is short but I have all the commands and descriptions.. it's just the implementation of them that I need to learn.

    Thanks a million

  8. #8
    Join Date
    Sep 2010
    Posts
    26
    Rep Power
    5

    Default Spaces

    Quote Originally Posted by DEpple View Post
    I have setup zimbraDomainmandatoryMailSignature correctly... but when I try to restart Amavis to apply the configuration, it says it must be ran as a Zimbra user..
    How do I run this as a Zimbra user? I thought root would work...
    Life is about the details. For anyone who comes across this thread.. from the terminal type the command as shown su (space) - (space) zimbra:
    su - zimbra

    From one newb to another.. hope this helps someone.

  9. #9
    Join Date
    Mar 2011
    Posts
    19
    Rep Power
    4

    Default

    has anyone managed to get this working on ZCS v7?

  10. #10
    Join Date
    Mar 2011
    Posts
    19
    Rep Power
    4

    Default Global Domain Disclaimer / Signature Configuration

    My Zimbra Configuration
    Release 7.1.1_GA_3196.RHEL5_64_20110527001604 CentOS5_64 NETWORK edition.

    Requirements
    Altermime
    #altermime installed by default in ZCS v7 but read for how it works / installs
    Adding a disclaimer (altermime) or footer - Zimbra :: Wiki

    Instructions on getting it to work
    #create disclaimer file in zimbra command line interface
    zmprov mcf zimbraDomainMandatoryMailSignatureEnabled TRUE
    zmprov mcf zimbraDomainMandatoryMailSignatureText "some text"
    zmprov mcf zimbraDomainMandatoryMailSignatureHTML "<html><body>some html text</body>/html>"
    #restart mail server
    zmcontrol restart
    #create disclaimer files (if not created by zimbra, which was the issue in my case)
    vim /opt/zimbra/data/altermime/global-default.txt
    #example file data
    some text
    #create html disclaimer file
    vim /opt/zimbra/data/altermime/global-default.html
    #example file data
    <html><body>some html text</body>/html>

    Once these files were created the domain signature / disclaimer was being appended to all email messages.

Similar Threads

  1. Replies: 7
    Last Post: 04-27-2009, 02:49 AM
  2. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  3. [SOLVED] Remove main domain!
    By zibra in forum Administrators
    Replies: 11
    Last Post: 09-27-2007, 08:50 AM
  4. how to add a same Signature for a domain
    By crossany in forum Developers
    Replies: 1
    Last Post: 06-08-2006, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •