Results 1 to 6 of 6

Thread: [SOLVED] export certificate to zimbra

Threaded View

  1. #1
    Join Date
    Feb 2011
    Posts
    5
    Rep Power
    4

    Default [SOLVED] export certificate to zimbra

    hi folks,

    i already read tutorials about import certificates to zimbra in wiki, but i don't get import the certificates from my external openldap server, that authenticate zimbra users , so when i check the option to use ssl, a series of warms shows in the debug box, alert me that certificate is not valid...

    i configured my certicates and CA as follow, using openssl:

    #generate CA
    $ /usr/lib/ssl/misc/CA.pl -newca

    #generate certificates
    $ /usr/lib/ssl/misc/CA.pl -newreq

    # so i have the private key (newkey.pem), and the public key (newreq.pem)

    #i sign the certificate
    $ /usr/lib/ssl/misc/CA.pl -sign

    # this generate a sign public key called newcert.pem

    # now i remove the password from private key
    $ openssl rsa -in newkey.pem -out newkey.nopass.pem

    # In final i have this files
    newcert.pem newkey.nopass.pem newkey.pem newreq.pem

    # and my ca is called cacert.pem

    in slapd.conf i set TLSVerifyClient as never...

    so folks, how can i solve this problem ?

    ps. sorry about my english
    Last edited by diegolcf; 02-22-2011 at 06:16 PM.

Similar Threads

  1. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 03:37 AM
  2. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  3. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 04:48 PM
  4. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  5. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •