Our mail server has recently gotten the issue where the antivirus has stopped due to a malformed clamav database.

After searching for fixes online, we restarted the server and disabled the antivirus. It's a temporary solution, so we decided to download the latest clamav signatures.

However when checking the log we now have the following issue:

Mon Feb 28 15:21:57 2011 -> Reading databases from /opt/zimbra/data/clamav/db
Mon Feb 28 15:21:57 2011 -> Not loading PUA signatures.
LibClamAV Warning: ************************************************** *********
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ************************************************** *********
LibClamAV Error: Incorrect offset 'VI' in subsignature id 0 for signature type-1
LibClamAV Error: Problem parsing database at line 116
LibClamAV Error: Can't load daily.ldb: Malformed database
LibClamAV Error: cli_tgzload: Can't load daily.ldb
LibClamAV Error: Can't load /opt/zimbra/data/clamav/db/daily.cld: Malformed database
Mon Feb 28 15:21:57 2011 -> ERROR: Malformed database
ERROR: Malformed database


This clearly means it won't work.

Has anyone had this problem and managed to get it working? Preferably without updating the clamav engine.