Results 1 to 5 of 5

Thread: [SOLVED] Logos and Branding, File Location on Server

  1. #1
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default [SOLVED] Logos and Branding, File Location on Server

    Version: ZCS 6.10 NE, 7 shortly
    Files: 120x35.png & 450x100.png
    Location?: /opt/zimbra/jetty/webapps/zimbra/skins/

    1) Using the admin console gui, where should the image files be stored on the Zimbra server?
    2) With what permissions?
    3) What is the location for the two location fields?
    Application logo banner URL of the themes:
    Login logo banner URL of the themes:

    Please don't just reply with a link to the Wiki. Those documents are near worthless as they are out of date. They were made for 4.5 with slight notes for 5.0 and have no mention of 6 or 7. There is no mention of the admin console section and I need this to be easy for later admins other than myself. The built-in help pages are no help as well.

    4) Also on a side note, is there an internal location on the Zimbra server we can host image files for use in signatures rather than offsite?


    EDIT: Here is my solution. I stored the files in the skins folder, but on another webserver or elsewhere on your mail server should work also.

    Code:
    Admin Console > Domains > @domain.com > Themes
    
    Application logo banner URL of the themes: https://url.domain.com/zimbra/skins/200x28_glow.png
    Login logo banner URL of the themes: https://url.domain.com/zimbra/skins/300x48_glow.png
    Last edited by quietas; 04-26-2011 at 08:17 AM.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  2. #2
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    1) It looks like if I just dump them in the /opt/zimbra/jetty/webapps/zimbra/skins/ folder it works.

    2) I copied then over via SCP and the root user, didn't change from the default 644 and it works fine.

    3) Use https://mail.domain.com/zimbra/skins/file.png as the locations it will work.

    Simple once I fiddled with it enough. Why isn't this documented?

    4) Is it advisable to put company/domain signature image files there as well?

    5) New question: Will these files be deleted with an update like my whitelist/blacklist in the salocal.cf.in file?
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  3. #3
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    Past posts which directed NE users to the official branding documentation were done with a view that the FOSS license does not grant custom branding rights. While some FOSS users will not adhere to the license restrictions regardless, historically we have tried not to post specific branding how-to's here in the public forums.

    Having said that, I totally agree the branding documentation is both way out date and inapplicable to the Carbon theme in ZCS 7.

    We posted in the private forum for Zimbra Partners on this and everyone is feeling their way through the same problem.

    Since you paid for NE, you have a right to custom brand it as you see fit. In that regard, I would recommend that you are well within your rights to open a support ticket with Zimbra on this issue.

    And if you get a link to the ZCS7 Branding Documentation (assuming it exists) please send me a PM with the link--I'll do the same if I hear first!

    S'OK?

    All the best,
    Mark

  4. #4
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    Good idea, I think I'll do that in preparation for our upgrade to 7 later this month.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  5. #5
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    I forgot to reply back with the fix. It marked the thread solved and added the solution to the first post.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

Similar Threads

  1. branding boo-boo
    By admin1 in forum Administrators
    Replies: 2
    Last Post: 03-26-2008, 08:43 AM
  2. Branding themes - some observations on logos
    By globalstorm in forum Users
    Replies: 12
    Last Post: 11-22-2006, 01:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •