Results 1 to 4 of 4

Thread: [SOLVED] smtp Authentication problem

  1. #1
    Join Date
    Dec 2010
    Rep Power

    Default [SOLVED] smtp Authentication problem

    Hi all,

    I need help to authenticate all outgoing mail through my ISP's MTA, I tried to use the Outgoing SMTP Authentication article in the wiki page of zimbra but i can't authenticate in my isp smtp server.

    i added the followings comand to my server:
    1. zmprov ms zimbraMtaRelayHost
    2. echo usernameassword > /opt/zimbra/conf/relay_password
    3. postmap hash:/opt/zimbra/conf/relay_password
    4. postmap -q /opt/zimbra/conf/relay_password
    5. postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    6. postconf -e smtp_cname_overrides_servername=no
    7. postfix reload
    I didn't add the ssl authentication and tls because my ISP technical suport, said they didn't use any of them .
    to make persistent i add the following comands:
    zmlocalconfig -e postfix_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
    zmlocalconfig -e postfix_smtp_sasl_security_options=noplaintext,noa nonymous
    zmlocalconfig -e postfix_smtp_sasl_mechanism_filter=login
    zmlocalconfig -e postfix_smtp_use_tls=no
    zmlocalconfig -e postfix_smtp_use_ssl=no
    zmlocalconfig -e postfix_smtp_cname_overrides_servername=no
    In the zimbra log file /var/log/zimbra.log i get the following error:
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: C0307480AA5: to=<>,[]:25, delay=4.3, delays=0.02/0.03/0.03/4.2, dsn=5.0.0, status=bounced (host[] said: 550 relaying blocked, read new mail, add to forwarding or enable smtp authentication in (in reply to RCPT TO command))
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: rec_put_type: 68 at 639
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: vstream_fflush_some: fd 13 flush 1
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: >[]:25: RSET
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: vstream_fflush_some: fd 14 flush 6
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: vstream_buf_get_ready: fd 14 got 21
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: <[]:25: 250 Command RSET OK
    Mar 2 19:01:00 zimbra postfix/smtp[6600]: >[]:25: QUIT

    just two notes:

    first: my mail server is in dmz behind cisco firewall with pat address translation.
    second: zimbraMtaAuthEnabled is set to TRUE

    Thank you so much in advance, and I will be looking forward for any help provided to solve this matter.

  2. #2
    Join Date
    Oct 2009
    Rep Power


    xxx.yourisp_mailserver.tld - is to be replaced with your ISP email server domain, fully qualified name
    xxx.yourzimbradomain.tld - is to be replaced with whatever domain you setup zimbra on, fully qualified name

    Here's what my authentication looks like.

    zmprov ms xxx.yourzimbradomain.tld zimbraMtaRelayHost xxx.yourisp_mailserver.tld:25;
    echo xxx.yourisp_mailserver.tld userid@xxx.yourisp_mailserver.tldassword > /opt/zimbra/conf/relay_password;
    postmap hash:/opt/zimbra/conf/relay_password;

    postmap -q xxx.yourisp_mailserver.tld /opt/zimbra/conf/relay_password;
    postconf -e smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password;
    postconf -e smtp_sasl_auth_enable=yes;

    postconf -e smtp_use_tls=yes;
    postfix reload;
    postconf -e smtp_cname_overrides_servername=no;
    postconf -e smtp_sasl_security_options=noanonymous
    postfix reload;

    zmlocalconfig -e postfix_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password;
    zmlocalconfig -e postfix_smtp_sasl_auth_enable=yes;
    zmlocalconfig -e postfix_smtp_use_tls=yes;
    zmlocalconfig -e postfix_smtp_cname_overrides_servername=no;
    zmlocalconfig -e postfix_smtp_sasl_security_options=noanonymous;

    zmprov mcf zimbraLastLogonTimestampFrequency 1h;
    zmprov mcf zimbraDefaultDomainName yourzimbradomain.tld;
    zmprov mc default zimbraFeatureCalendarReminderDeviceEmailEnabled TRUE;

    Do this only if you're running Zimbra FOSS 7
    as root, after upgrade or install

    Last thing, you need to be sure your split DNS is setup and working properly if you are sitting behind a NAT. I assume that's all good.

  3. #3
    Join Date
    Dec 2010
    Rep Power

    Smile smtp auth Working

    Hi Spectra,

    I Just applied the configuration you post, and my smtp auth is working fine
    thank you for your assistance

  4. #4
    Join Date
    Feb 2014
    Rep Power

    Question Need some more details..

    [QUOTE=nunomartins80;211654]Hi Spectra,

    I Just applied the configuration you post, and my smtp auth is working fine
    thank you for your assistance[/QUO

    echo usernameassword > /opt/zimbra/conf/relay_password

    in this following command,can i use our global administrator passwd..?
    otherwise,kindly explain,which username and passwd can we use..?

    Zimbra version 8.0.5

    Thanks in Advance.

Similar Threads

  1. SMTP authentication problem
    By old-cow in forum Administrators
    Replies: 7
    Last Post: 11-05-2008, 11:10 AM
  2. SMTP authentication problems continue
    By EdMartin in forum Installation
    Replies: 2
    Last Post: 01-11-2008, 02:23 AM
  3. smtp table lookup problem
    By s_c_johnson in forum Installation
    Replies: 5
    Last Post: 09-21-2007, 05:46 AM
  4. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts