Results 1 to 4 of 4

Thread: Error deploying a zimlet from the gallery

  1. #1
    Join Date
    Aug 2010
    Location
    In yours
    Posts
    93
    Rep Power
    5

    Default Error deploying a zimlet from the gallery

    Hi folks,

    I get the zimlet zimbraSambaPassword Extension and when i try to deploy this zimlet by terminal appear this error:

    zimlets$ zmzimletctl install zimbraSambaPassword.zip
    java.io.FileNotFoundException: zimlet description not found: zimbrasambapassword.xml
    at com.zimbra.cs.zimlet.ZimletFile.initZimletDescript ion(ZimletFile.java:250)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:206)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:163)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:144)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1795)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1888)
    [] ERROR: Error
    java.io.FileNotFoundException: zimlet description not found: zimbrasambapassword.xml
    at com.zimbra.cs.zimlet.ZimletFile.initZimletDescript ion(ZimletFile.java:250)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:206)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:163)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:144)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1795)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1888)
    zimbra@zimbra:~/zimlets$


    If I do:

    ~/zimlets$ zmzimletctl deploy zimbraSambaPassword.zip
    [] INFO: Deploying on zimbra.dip-badajoz.es
    [] INFO: Deploy initiated. (check the servers mailbox.log for the status)


    And this is the zimlet's list

    /zimlets$ zmzimletctl listZimlets
    Installed Zimlet files on this host:
    [] WARN: error loading zimlet com_zimbra_saldo
    java.io.FileNotFoundException: zimlet description not found: com_zimbra_saldo.xml
    at com.zimbra.cs.zimlet.ZimletFile.initZimletDescript ion(ZimletFile.java:250)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:206)
    at com.zimbra.cs.zimlet.ZimletFile.initialize(ZimletF ile.java:163)
    at com.zimbra.cs.zimlet.ZimletFile.<init>(ZimletFile. java:149)
    at com.zimbra.cs.zimlet.ZimletUtil.loadZimletsFromDir (ZimletUtil.java:400)
    at com.zimbra.cs.zimlet.ZimletUtil.loadZimlets(Zimlet Util.java:337)
    at com.zimbra.cs.zimlet.ZimletUtil.listInstalledZimle tsOnHost(ZimletUtil.java:926)
    at com.zimbra.cs.zimlet.ZimletUtil.listAllZimlets(Zim letUtil.java:995)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUti l.java:1772)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.ja va:1888)
    com_zimbra_adminversioncheck
    com_zimbra_baja
    com_zimbra_bulkprovision
    com_zimbra_cert_manager
    com_zimbra_date
    com_zimbra_dnd
    com_zimbra_email
    com_zimbra_phone
    com_zimbra_registro_usuario
    com_zimbra_rssfeeds
    com_zimbra_url
    com_zimbra_validacion
    com_zimbra_ymemoticons
    zimbra_samba
    Installed Zimlets in LDAP:
    com_zimbra_baja
    com_zimbra_date (disabled)
    com_zimbra_dnd
    com_zimbra_email
    com_zimbra_phone (disabled)
    com_zimbra_registro_usuario (disabled)
    com_zimbra_rssfeeds
    com_zimbra_url
    com_zimbra_validacion
    com_zimbra_ymemoticons
    Available Zimlets in COS:
    ciudadano:
    com_zimbra_date
    com_zimbra_dnd
    com_zimbra_email
    com_zimbra_phone
    com_zimbra_url
    com_zimbra_ymemoticons
    default:
    com_zimbra_baja
    com_zimbra_date
    com_zimbra_dnd
    com_zimbra_email
    com_zimbra_phone
    com_zimbra_registro_usuario
    com_zimbra_rssfeeds
    com_zimbra_url
    com_zimbra_validacion
    com_zimbra_ymemoticons
    zimbra@zimbra:~/zimlets$


    Any help???

    Thanks

  2. #2
    Join Date
    Mar 2011
    Posts
    131
    Rep Power
    4

    Default

    Yes, I am getting the same error. I don't know how to get ride of it. I am just executing helloworld kinda zimlet.

  3. #3
    Join Date
    Sep 2009
    Location
    France
    Posts
    9
    Rep Power
    6

    Default

    Is there a directory into the zip file ?
    ZimGuy

    Zimbra V7 OSS Ubuntu 10.04 LTS 64 Bits
    CAS 3.3.5 SPNEGO

  4. #4
    Join Date
    Feb 2012
    Posts
    81
    Rep Power
    3

    Default

    I ran into similar problems when I tried to keep the version number in the zimlet zip file name. Turned out that zimlet structure is quite restricted.

    * the zimlet's name is taken by stripping the .zip suffix from the zipfile name
    * there *must* be a file <zimlet_name>+".xml" in the root directory of the zimlet archive.
    * all other files which have to be deployed must be properly described in the xml file.
    * additional jar files are copied to $ZIMBRA_ROOT/lib/jars/

    The last point turns into a really, really tricky one. We must be *very careful* with zimlets including jar files:

    a) if multiple zimlets include jars with same name, they will overwrite each other on deployment (i guess, the last one wins)
    b) if multiple jars contain classes of same name, it's a game of luck which one will be loaded first and so which classes are actually linked in.

    Conclusion: we need some real package management (including dependency handling) for Zimbra.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 09:06 AM
  2. Outlook 2007 Beta error
    By bersrker in forum Zimbra Connector for Outlook
    Replies: 13
    Last Post: 07-17-2008, 07:38 AM
  3. Replies: 4
    Last Post: 02-24-2008, 01:29 PM
  4. Replies: 5
    Last Post: 01-11-2008, 04:34 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •