Results 1 to 2 of 2

Thread: [SOLVED] Upgrade from 5.0 to 7.0 error

  1. #1
    Join Date
    Aug 2007
    Location
    Barcelona
    Posts
    19
    Rep Power
    8

    Default [SOLVED] Upgrade from 5.0 to 7.0 error

    Hi,

    We've tried to upgrade our 5.0 zimbra version to 7.0 and it has crashed.

    Removing deployed webapp directories
    Installing packages

    zimbra-core......zimbra-core-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-ldap......zimbra-ldap-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-logger......zimbra-logger-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-mta......zimbra-mta-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-snmp......zimbra-snmp-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-store......zimbra-store-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-apache......zimbra-apache-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-spell......zimbra-spell-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-memcached......zimbra-memcached-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done
    zimbra-proxy......zimbra-proxy-7.0.0_GA_3077.SuSEES10-20110127201734.i386.rpm...done

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=domain.cat
    LDAPHOST=domain.cat
    LDAPPORT=7389
    SNMPTRAPHOST=domain.cat
    SMTPSOURCE=admin@domain.cat
    SMTPDEST=admin@domain.cat
    SNMPNOTIFY=yes
    SMTPNOTIFY=yes
    LDAPROOTPW=...
    LDAPZIMBRAPW=...
    LDAPPOSTPW=...
    LDAPREPPW=...
    LDAPAMAVISPW=...
    LDAPNGINXPW=...
    Restoring existing configuration file from /opt/zimbra/.saveconfig/localconfig.xml...done
    Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java :620)
    at java.security.SecureClassLoader.defineClass(Secure ClassLoader.java:124)
    at java.net.URLClassLoader.defineClass(URLClassLoader .java:260)
    at java.net.URLClassLoader.access$100(URLClassLoader. java:56)
    at java.net.URLClassLoader$1.run(URLClassLoader.java: 195)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:188)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:3 06)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launche r.java:268)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:2 51)
    at java.lang.ClassLoader.loadClassInternal(ClassLoade r.java:319)
    Any help would be appreciated.
    Ricard

  2. #2
    Join Date
    Aug 2007
    Location
    Barcelona
    Posts
    19
    Rep Power
    8

    Default

    It was our mistake.

    Before the upgrade, we did a backup, but all the soft-links from /opt/zimbra were copied as directories.
    When we tried to do the upgrade with this backup copy, as no soft-link exists in /opt/zimbra, this error had appeared.
    We will try to do a new backup maintaining the soft-links.

    Thanks,
    Ricard
    Last edited by riravedra; 03-15-2011 at 11:15 AM.

Similar Threads

  1. Upgrade from 6.0.10 to 7 beta4
    By alex70 in forum Installation
    Replies: 14
    Last Post: 05-11-2012, 03:02 PM
  2. Upgrade to Zimbra 7 - Table upgrade required
    By n8bounds in forum Administrators
    Replies: 10
    Last Post: 04-26-2011, 12:07 AM
  3. Replies: 6
    Last Post: 03-14-2011, 05:21 AM
  4. [SOLVED] New zcs 7 install : database errors founds
    By dkbk in forum Administrators
    Replies: 4
    Last Post: 03-01-2011, 06:49 AM
  5. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •