Results 1 to 2 of 2

Thread: Sending huge eMails from shell

Hybrid View

  1. #1
    Join Date
    May 2006
    Posts
    83
    Rep Power
    9

    Default Sending huge eMails from shell

    Hello,

    I increased the MTA mail size to send emails larger than 30MB (i set the limit to 256MB) - But I ran into trouble with the milter-server now...

    Running ZCS 7.0.1 on Ubuntu 64Bit
    The result in shell with activated Milter:
    Code:
    sendEmail[6460]: ERROR => Received: 	451 4.7.1 Service unavailable - try again later
    The Logfile:
    Code:
    Mar 20 09:09:43  postfix/smtpd[10891]: connect from DOMAIN[x.x.x.x]
    Mar 20 09:09:43  postfix/smtpd[10891]: setting up TLS connection from DOMAIN[x.x.x.x]
    Mar 20 09:09:43  postfix/smtpd[10891]: Anonymous TLS connection established from DOMAIN[x.x.x.x]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    Mar 20 09:09:43  saslauthd[32614]: zmauth: authenticating against elected url 'https://DOMAIN:7071/service/admin/soap/' ...
    Mar 20 09:09:44  saslauthd[32614]: zmpost: url='https://DOMAIN:7071/service/admin/soap/' returned buffer->data='<soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Header><context xmlns="urn:zimbra"><change token="21990"/></context></soap:Header><soap:Body><AuthResponse xmlns="urn:zimbraAccount"><authToken>0_1ee5b85bfd712e8906eeff7149201b4b241256bd_69643d33363a30326562353665642d613636332d343862322d623439622d3038666537356132343633633b6578703d31333a313330303738313338333939343b76763d313a313b747970653d363a7a696d6272613b</authToken><lifetime>172800000</lifetime><skin>waves</skin></AuthResponse></soap:Body></soap:Envelope>', hti->error=''
    Mar 20 09:09:44  saslauthd[32614]: auth_zimbra: mario auth OK
    Mar 20 09:09:44  postfix/smtpd[10891]: 2F5F2612001: client=DOMAIN[x.x.x.x], sasl_method=LOGIN, sasl_username=mario
    Mar 20 09:09:44  postfix/cleanup[10895]: 2F5F2612001: message-id=<608389.106436761-sendEmail@DOMAIN>
    Mar 20 09:10:02  zimbramon[10924]: 10924:info: 2011-03-20 09:10:02, QUEUE: 0 0
    Mar 20 09:10:31  zmmailboxdmgr[11771]: status requested
    Mar 20 09:10:31  zmmailboxdmgr[11771]: status OK
    Mar 20 09:10:39  clamd[7410]: Pid file removed.
    Mar 20 09:10:39  clamd[7410]: --- Stopped at Sun Mar 20 09:10:39 2011
    Mar 20 09:10:48  clamd[12243]: clamd daemon 0.97-broken-compiler (OS: linux-gnu, ARCH: x86_64, CPU: x86_64)
    Mar 20 09:10:48  clamd[12243]: Log file size limited to 20971520 bytes.
    Mar 20 09:10:48  clamd[12243]: Reading databases from /opt/zimbra/data/clamav/db
    Mar 20 09:10:48  clamd[12243]: Not loading PUA signatures.
    Mar 20 09:11:06  clamd[12243]: Loaded 919812 signatures.
    Mar 20 09:11:08  clamd[12243]: TCP: Bound to address 127.0.0.1 on port 3310
    Mar 20 09:11:08  clamd[12243]: TCP: Setting connection queue length to 200
    Mar 20 09:11:08  clamd[12267]: Limits: Global size limit set to 262144000 bytes.
    Mar 20 09:11:08  clamd[12267]: Limits: File size limit set to 262144000 bytes.
    Mar 20 09:11:08  clamd[12267]: Limits: Recursion level limit set to 16.
    Mar 20 09:11:08  clamd[12267]: Limits: Files limit set to 10000.
    Mar 20 09:11:08  clamd[12267]: Archive support enabled.
    Mar 20 09:11:08  clamd[12267]: Archive: Blocking encrypted archives.
    Mar 20 09:11:08  clamd[12267]: Algorithmic detection enabled.
    Mar 20 09:11:08  clamd[12267]: Portable Executable support enabled.
    Mar 20 09:11:08  clamd[12267]: ELF support enabled.
    Mar 20 09:11:08  clamd[12267]: Mail files support enabled.
    Mar 20 09:11:08  clamd[12267]: OLE2 support enabled.
    Mar 20 09:11:08  clamd[12267]: PDF support enabled.
    Mar 20 09:11:08  clamd[12267]: HTML support enabled.
    Mar 20 09:11:08  clamd[12267]: Self checking every 600 seconds.
    Mar 20 09:11:12  postfix/postfix-script[12307]: refreshing the Postfix mail system
    Mar 20 09:11:12  postfix/master[32598]: reload -- version 2.7.2, configuration /opt/zimbra/postfix-2.7.2.2z/conf
    Mar 20 09:12:18  zmmailboxdmgr[12608]: status requested
    Mar 20 09:12:18  zmmailboxdmgr[12608]: status OK
    Mar 20 09:12:50  postfix/cleanup[10895]: warning: milter inet:127.0.0.1:7026: can't read SMFIC_HEADER reply packet header: Success
    Mar 20 09:12:50  postfix/cleanup[10895]: 2F5F2612001: milter-reject: END-OF-MESSAGE from DOMAIN[x.x.x.x]: 4.7.1 Service unavailable - try again later; from=<mario@DOMAIN> to=<mario@DOMAIN> proto=ESMTP helo=<DOMAIN>
    When I switch off Milter then the huge eMail will be sent without any trouble!
    (It is an attachment/pdf with about 30MB - sent by sendEmail)

    Is there a way to send huge eMails with activated milter??

    Best regards,
    Mario

    Edit: Result of postconf:
    Code:
    postconf |grep size        
    berkeley_db_create_buffer_size = 16777216
    berkeley_db_read_buffer_size = 131072
    body_checks_size_limit = 51200
    bounce_size_limit = 50000
    header_size_limit = 102400
    mailbox_size_limit = 0
    message_size_limit = 262144000
    tcp_windowsize = 0

  2. #2
    Join Date
    Jul 2011
    Posts
    6
    Rep Power
    4

    Default

    Hi:

    Seems to be a timeout between the milter server and postfix. When the cleanup server pass throught the conections it cuts off them.

    We solved it adding:

    milter_default_action=accept

    into main.cf

    Let us know if this solve it for you

Similar Threads

  1. sending emails and progress of sending
    By mokuti in forum General Questions
    Replies: 1
    Last Post: 04-01-2013, 06:58 AM
  2. Delay the sending of emails.
    By micasrafael in forum Administrators
    Replies: 4
    Last Post: 05-08-2012, 08:48 PM
  3. How to stop Zimbra sending out meeting invite emails?
    By schvenk in forum Administrators
    Replies: 2
    Last Post: 03-02-2008, 12:58 PM
  4. Replies: 3
    Last Post: 07-19-2007, 03:00 AM
  5. Zimbra server stopped sending emails
    By netwerkdude in forum Installation
    Replies: 20
    Last Post: 04-23-2007, 12:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •