On my last Zimbra upgrade, I re-enabled zmlogger (previously disabled due to performance problems in Zimbra 5.x) and finally got my Daily Reports flowing again.

I am now aware of this error in my logs:

Mar 23 10:24:34 zimbra postfix/postdrop[23653]: warning: mail_queue_enter: create file maildrop/750341.23653: Permission denied

and it seems to be hitting every 10 seconds. I haven't heard of any user complaints about mail not getting delivered, so whatever this is isn't affecting anyone with a pulse.

I've browsed the fora and found some references to this type of symptom, but nothing that diagnosed my particular situation.

My reference Zimbra installs (stage and test environments) don't exhibit this. I'm suspecting a load issue or a config somewhere I missed.

FWIW:

zimbra@zimbra:/var/log$ zmlocalconfig postfix_queue_directory
postfix_queue_directory = ${zimbra_home}/data/postfix/spool

root@zimbra:/opt/zimbra# ls -la /opt/zimbra/data/postfix/spool
total 96
drwxr-xr-x 16 postfix postfix 4096 2010-07-17 16:59 .
drwxr-xr-x 3 postfix zimbra 4096 2010-10-30 12:10 ..
drwx------ 2 postfix postfix 20480 2011-03-23 10:36 active
drwx------ 2 postfix postfix 4096 2011-03-23 02:00 bounce
drwx------ 2 postfix postfix 4096 2010-07-17 16:59 corrupt
drwx------ 18 postfix postfix 4096 2010-09-09 17:42 defer
drwx------ 18 postfix postfix 4096 2010-09-09 17:42 deferred
drwx------ 2 postfix postfix 4096 2010-07-17 16:59 flush
drwx------ 2 postfix postfix 4096 2010-10-13 08:36 hold
drwx------ 2 postfix postfix 20480 2011-03-23 10:36 incoming
drwx-wx--- 2 postfix postdrop 4096 2011-03-23 07:16 maildrop
drwxr-xr-x 2 postfix root 4096 2010-12-17 15:01 pid
drwx------ 2 postfix postfix 4096 2011-03-19 12:35 private
drwx--x--- 2 postfix postdrop 4096 2011-03-19 12:35 public
drwx------ 2 postfix postfix 4096 2010-07-17 16:59 saved
drwx------ 2 postfix postfix 4096 2011-03-04 10:59 trace


Can anyone here shed light on this one? Thanks!
mike r.