Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Server Status data is not available.

  1. #1
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default Server Status data is not available.

    Hello,

    Installed fresh/new Zimbra server. I am receiving this error on the Admin GUI Server status page: "Server Status data is not available. To see the server status, logger service must be installed." Where I should look for problems?


    Code:
    zimbra@e-tag:~> zmcontrol status
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Running
            mailbox                 Running
            memcached               Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
            zmconfigd               Running

  2. #2
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    There is a brief troubleshooting guide here.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If this is a single server you also should not have the imapproxy or memcached installed or running - details on how to remove and uninstall those services are in the forums.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default

    There is output:


    Code:
    zimbra@e-tag:~> zmloggerctl status; echo $?; ps ax | grep zmlogger
    0
    21536 ?        Z      0:00 [zmlogger] <defunct>
    21602 ?        S      0:00 zmlogger: zmrrdfetch: server
    31029 ?        Z      0:00 [zmlogger] <defunct>
    31122 pts/2    S+     0:00 grep zmlogger
    
    
    zimbra@e-tag:~> /opt/zimbra/libexec/zmrrdfetch -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    
    zimbra@e-tag:~> /opt/zimbra/libexec/zmrrdfetch -c -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    
    
    zimbra@e-tag:~> grep -w MTA /var/log/zimbra-stats.log
    zimbra@e-tag:~>
    
    
    zimbra@e-tag:~> zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
    ERROR: service.FAILURE (system failure: zimbraLogHostname is not configured)
    
    
    zimbra@e-tag:~> zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats @limit=1 | head -50
    ERROR: service.FAILURE (system failure: zimbraLogHostname is not configured)

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by aigarspolis View Post
    There is output:


    Code:
    zimbra@e-tag:~> zmloggerctl status; echo $?; ps ax | grep zmlogger
    0
    21536 ?        Z      0:00 [zmlogger] <defunct>
    21602 ?        S      0:00 zmlogger: zmrrdfetch: server
    31029 ?        Z      0:00 [zmlogger] <defunct>
    31122 pts/2    S+     0:00 grep zmlogger
    
    
    zimbra@e-tag:~> /opt/zimbra/libexec/zmrrdfetch -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    
    zimbra@e-tag:~> /opt/zimbra/libexec/zmrrdfetch -c -f zmmtastats
    no structure found for zmmtastats at /opt/zimbra/libexec/zmrrdfetch line 239.
    
    
    zimbra@e-tag:~> grep -w MTA /var/log/zimbra-stats.log
    zimbra@e-tag:~>
    
    
    zimbra@e-tag:~> zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats | head -20
    ERROR: service.FAILURE (system failure: zimbraLogHostname is not configured)
    
    
    zimbra@e-tag:~> zmsoap -z GetLoggerStatsRequest stats/@name=zmmtastats @limit=1 | head -50
    ERROR: service.FAILURE (system failure: zimbraLogHostname is not configured)
    The highlighted line would be the problem. What about the answer to the questions in my post above?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default

    Sorry, forget to answer. It's single server and I was removed these services.

  7. #7
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default

    How can I set up zimbraLogHostname ?

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by aigarspolis View Post
    Sorry, forget to answer. It's single server and I was removed these services.
    Then let's first see the status of the service.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default

    Her we go:


    Code:
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Stopped
                    zmlogswatchctl is not running
            mailbox                 Running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Running
            zmconfigd               Running

  10. #10
    Join Date
    Mar 2011
    Posts
    8
    Rep Power
    4

    Default

    Any ideas?

Similar Threads

  1. Server Status all red x and rrd data empty
    By mingus8686 in forum Administrators
    Replies: 3
    Last Post: 11-20-2010, 02:56 AM
  2. Server status data is not available
    By marcw in forum Installation
    Replies: 56
    Last Post: 05-02-2010, 05:09 PM
  3. Replies: 0
    Last Post: 06-19-2007, 02:24 AM
  4. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •